OpenSuSe15.4以Server模式安装配置网络

配置静态ip地址

编辑/etc/sysconfig/network/ifcfg-xxx (xxx是网卡设备名),此处是ifcfg-eth0

vi /etc/sysconfig/network/ifcfg-eth0

主要是为了实现静态ip的需求

IPADDR=192.168.1.111
NETMASK=255.255.255.0
BOOTPROTO=static

解释:
IPADDR 配置成你期望的ip地址,要在分配的网段内
NETMASK 通常都是255.255.255.0 具体也要看配置
BBOTPROTO static即为静态配置

配置网关

在ifcfg-xxx中配置GATEWAY是无效的,需要编辑/etc/sysconfig/network/routes

主要解决无法访问外网的问题,常见问题:

ping 一个公网ip 提示Network is unreachable

vi /etc/sysconfig/network/routes
default 192.168.33.1

解释
中间的ip地址即为网关地址,具体看分配的网关
具体解释可百度一下,大意是所有流量请求网关收发吧

配置DNS

网上普遍说修改/etc/resolv.conf 添加nameserver 8.8.8.8 等等类似的解决方案

在openSUSE 15.4 中该方案不太适用,修改完resolv.conf后重启network.service,resolv.conf就会重新生成为空的

当然也有类似其他设置以实现resolv.conf在网络服务重启时不被覆盖

但其实仔细阅读以下resolv.conf的注释,其实应该要修改其他配置文件

修改/etc/sysconfig/network/config,只修改NETCONFIG_DNS_STATIC_SERVERS配置

主要解决无法解析域名的问题,常见问题:

ping www.baidu.com 提示Name or service not known

vi /etc/sysconfig/network/config
NETCONFIG_DNS_STATIC_SERVERS='8.8.8.8 8.8.4.4'   //配置多个的时候用空格间隔开

解释
引号内的ip地址是DNS服务器地址
静态ip、网关、DNS都配置完成后,重启网络服务(当然任一过程配置完成后都可重启网络服务看下效果)

重启后的验证

service network restart

ip:执行ifconfig命令看下修改的xxx网卡对应的ipaddr是否对应的上

网关:执行route -n命令看下是否有destination为0.0.0.0 gateway为所配置的ip 的一行记录

dns:执行cat /etc/resolv.conf 看下该文件中是否自动生成了一行 nameserver xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx为所配置的DNS

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/6194

(0)
安屠生的头像安屠生
上一篇 2022年11月23日 下午3:02
下一篇 2022年11月24日 下午5:13

相关推荐

  • linux(Mac)下查看文件编码及修改编码

    查看文件编码 在Linux中查看文件编码可以通过以下几种方式: 1. 在Vim中可以直接查看文件编码 即可显示文件编码格式。如果你只是想查看其它编码格式的文件或者想解决用Vim查看文件乱码的问题,那么你可以在~/.vimrc 文件中添加以下内容: 这样,就可以让vim自动识别文件编码(可以自动识别UTF-8或者GBK编码的文件),其实就是依照 fileenc…

    2023年8月15日
    2.0K00
  • 安装linux/Centos系统出现An Unknown Error Has Occurred报错原因和解决方法

    今天在给一个客户重装系统的时候出现: An Unknown Error Has OccurredThis program has encountered an unknown error. You may report the buy below or quit the program. This program has encountered an unk…

    2024年3月25日
    2.3K00
  • 如何处理CentOS Failed to load SELinux policy

    CentOS 7在启动时,卡在进度条界面一直进不去系统,如下图所示: 我们可以通过按键盘的左右方向键,可以看到提示“Failed to load SELinux policy.”,这就是造成系统一直卡住无法正常启动的原因。 原因 是因为没有正确修改系统的selinux的配置,导致系统在启动时报selinux的错误 解决方案 第一步:先重启CentOS7操作系…

    2022年6月15日
    2.2K00
  • 在 Kubernetes 上最小化安装 KubeSphere

    除了在 Linux 机器上安装 KubeSphere 之外,您还可以将其直接部署在现有的 Kubernetes 集群上。本快速入门指南将引导您完成在 Kubernetes 上最小化安装 KubeSphere 的一般性步骤。 准备工作 备注 部署 KubeSphere 确保您的机器满足安装的前提条件之后,可以按照以下步骤安装 KubeSphere。 执行以下命…

    2023年4月18日
    1.6K00
  • Centos7.6下宝塔安装及资产管理系统部署

    一:宝塔安装 1、连接linux服务器 2、执行命令开始安装 yum install -y wget && wget -O install.sh http://download.bt.cn/install/install_6.0.sh && sh install.sh ed8484bec 安装成功出现下方界面 3、访问外网地址…

    2022年6月8日
    5.8K90

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信