Nginx报 libraries: libgd.so.3错误

  • 在宝塔下安装nginx后,启动程序,有如下报错
Nginx报 libraries: libgd.so.3错误
  • 进去系统,使用nginx -t 检查错误
[root@instance-ba0ly8r5 ~]# nginx -t
nginx: error while loading shared libraries: libgd.so.3: cannot open shared object file: No such file or directory

通过检查发现,是缺少 libgd.so.3,缺少gd库

  • 安装gd库
[root@instance-ba0ly8r5 ~]# yum install -y gd
  • 重新启动nginx,正常启动
Nginx报 libraries: libgd.so.3错误

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/5230

赞 (0)
郭靖的头像郭靖
上一篇 2022年7月5日 下午5:23
下一篇 2022年7月7日 下午4:48

相关推荐

  • IIS发布网站时报403错误的所有原因及解决方案

    在使用IIS的时候,如果遇到403相关的错误,我们往往束手无策,不知道是什么权限的原因。现总结如下,供以后参考。 1、403.1 – 执行访问被禁止 没有足够的执行权限,例如你访问的index.php文件,但是该文件并没有执行权限,那么浏览器在访问时就会出现该错误,然后你就需要去修改目录的权限了 2、403.2 – 读访问被禁止验证是…

    2022年6月21日
    3.2K00
  • 解决Composer Installing dependencies from lock file

    1、问题描述 2、原因 这是因为不匹配composer.json要求的版本。提示我的PHP 7版本太高,不符合composer.json需要的版本,但是在PHP 7下应该也是可以运行的,composer可以设置忽略版本匹配。 3、解决方案 composer install –ignore-platform-reqs 或者 composer update -…

    2023年2月14日
    2.1K00
  • Tomcat日志切割工具 logrotate

    Tomcat日志切割工具 logrotate 在我们生产环境中经常遇到tomcat log清理的问题,曾经做过实验通过重定向的方式把日志清空,但是发现日志tomcat里面的catalina.out不输出日志了。这时候我们可以考虑一下日志管理工具Logrotate 一、日志工具Logrotate简介 二、Logrotate运行机制 系统会定时运行logrota…

    2023年3月24日
    1.5K00
  • Nginx⽇志切割

    ⼀:切割 ⼆:清理 三:添加定时任务

    2023年5月9日
    1.9K00
  • LNMP黄金架构的搭建

    LNMP组合工作流程 LNMP工作流是用户通过浏览器输入域名访问Nginx web服务,Nginx判断请求是静态请求则由Nginx返回给用户。如果是动态请求(如.php结尾),那么Nginx会将该请求通过FastCGI接口发送给PHP引擎(php-fpm进程)进行解析,如果该动态请求需要读取mysql数据库,php会继续向后读取数据库,最终Nginx将获取的…

    2022年7月7日
    2.2K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信