Nginx报 libraries: libgd.so.3错误

  • 在宝塔下安装nginx后,启动程序,有如下报错
Nginx报 libraries: libgd.so.3错误
  • 进去系统,使用nginx -t 检查错误
[root@instance-ba0ly8r5 ~]# nginx -t
nginx: error while loading shared libraries: libgd.so.3: cannot open shared object file: No such file or directory

通过检查发现,是缺少 libgd.so.3,缺少gd库

  • 安装gd库
[root@instance-ba0ly8r5 ~]# yum install -y gd
  • 重新启动nginx,正常启动
Nginx报 libraries: libgd.so.3错误

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/5230

(0)
郭靖的头像郭靖
上一篇 2022年7月5日 下午5:23
下一篇 2022年7月7日 下午4:48

相关推荐

  • nginx安全:配置allow/deny控制ip访问

    一,nginx中allow/deny指令的用途 1, Nginx的deny和allow指令是由ngx_http_access_module模块提供, Nginx安装默认内置了该模块 2, nginx访问控制模块: 想禁止哪个ip访问就加上deny IP, 想允许哪个ip访问就加上allow IP, 想禁止或者允许所有,则allow all或者deny all…

    2023年3月1日
    1.8K00
  • 解决Composer Installing dependencies from lock file

    1、问题描述 2、原因 这是因为不匹配composer.json要求的版本。提示我的PHP 7版本太高,不符合composer.json需要的版本,但是在PHP 7下应该也是可以运行的,composer可以设置忽略版本匹配。 3、解决方案 composer install –ignore-platform-reqs 或者 composer update -…

    2023年2月14日
    2.1K00
  • 如何修改WordPress底部版权信息?

    wordpress安装之后,有不少默认设置需要我们修改,wordpress网站底部版权信息就是其中之一,在网站最下面页脚那个位置,会有一段英文声明,如下所示。 © 2019 My WordPress Proudly powered by WordPress 如果你使用的不是wordpress默认主题,底部版权信息会根据wordpress主题的不同,被开发者写…

    2024年1月29日
    3.0K00
  • 解决discuz论坛搬家:“Table ‘common_syscache’ is read only”问题

    网站搬家采用直接打包mysql数据库和网页文件的形式进行迁移,上传好mysql data目录里面的网站数据库至mysql存放数据库的目录里面,解压就行,我的存放数据库的路径是 /usr/local/mysql/var,上传好网站数据,解压,配置好数据库链接参数就行,网站就能正常连接上了,我本以为这已经是顺利迁移完成了,但后来操作的时候,发现只能读取数据库的内…

    2023年2月15日
    1.5K00
  • Linux 宝塔部署 ASP.NET Core 应用

    第一步,发步应用 我这是一个API 应用和 MVC 应用 设置,服务器上要运行的端口 API 端口5000 MVC 端口5001 打包文件夹,发步 1、桌面新建俩个文件夹 2、右键项目发步,选中iis 目标位置选择刚刚桌面上创建的API文件夹 MVC 同理,这里不做演示 第二步、安装LInux ASP.NET Core 运行时环境 1、连接服务器 2、执行以…

    2023年3月8日
    2.6K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信