Linux 宝塔部署 ASP.NET Core 应用

第一步,发步应用

我这是一个API 应用和 MVC 应用

设置,服务器上要运行的端口

API 端口5000

Linux 宝塔部署 ASP.NET Core 应用

MVC 端口5001

Linux 宝塔部署 ASP.NET Core 应用

打包文件夹,发步

1、桌面新建俩个文件夹

Linux 宝塔部署 ASP.NET Core 应用

2、右键项目发步,选中iis

Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

目标位置选择刚刚桌面上创建的API文件夹

Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

MVC 同理,这里不做演示

第二步、安装LInux ASP.NET Core 运行时环境

1、连接服务器

Linux 宝塔部署 ASP.NET Core 应用

2、执行以下命令 (在Linux 鼠标右键复制粘贴)

sudo rpm -Uvh https://packages.microsoft.com/config/centos/7/packages-microsoft-prod.rpm
复制代码
Linux 宝塔部署 ASP.NET Core 应用
 sudo yum install dotnet-sdk-3.1
复制代码
Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

耐心等待下载(停顿下时,Y 一下),安装完成

Linux 宝塔部署 ASP.NET Core 应用

第三步,利用宝塔,将我们打包的项目文件上传到服务器

Linux 宝塔部署 ASP.NET Core 应用

把打包发步的俩个文件夹上传上来

Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

第四步,运行项目,浏览器访问

1、首先,在终端进入项目所在的文件,启动运行

Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

运行你项目的dll文件

Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

注意!这样运行项目,当你退出时,项目也将退出,我们必须保证项目一直在服务器运行所以,执行以下命令(Ctrl + C 退出)

退出后,执行 nohup dotnet Loans.API.dll

Linux 宝塔部署 ASP.NET Core 应用

然后直接关闭终端,重新连接在对MVC 做同样的事情,记得把MVC中API的地址换成你服务器的地址(如果你是只有一个MVC项目就不必了,我这是API+MVC 所以的弄俩下)

2、其次开放防火墙端口,以及安全组端口(安全组,自行操作,不做演示)

Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

第五步,浏览器运行

Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用
Linux 宝塔部署 ASP.NET Core 应用

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/7542

赞 (0)
郭靖的头像郭靖
上一篇 2023年3月8日 下午4:49
下一篇 2023年3月9日 下午4:26

相关推荐

  • Discuz! Database Error的解决办法

    原因一:数据库表太大 比如mysql数据库的表内容太大,超过10G就有可能会影响discuz论坛的运行。 这种情况可以通过对数据库分表的方法来解决。 原因二:数据库配置错误 有时候可能是主机搬家、数据库搬家等,造成数据库信息填写错误,或旧数据库信息没有及时更新等,比如数据库用户名、密码、数据库表填写错误等。 可以修正一下相关数据库信息即可,可以找到confi…

    2023年2月21日
    2.0K00
  • Discuz! X 3.4, 更新PHP7.4后无法打开uc_server的解决方案!

    页面报错:Deprecated: Array and string offset access syntax with curly braces is deprecated in/www/wwwroot/***/uc_server/admin.php on line53 出现报错原因: PHP7.4不再支持使用大括号访问数组以及字符串的偏移 将53行修改为:

    2023年7月31日
    12.8K00
  • IIS配置Url重写实现http自动跳转https的重定向方法

    需要准备的工具和环境: 操作流程 配置URL分为全局和非全局,下图,可以看到URL重写组件内容。 选择某一个站点中的URL重写,我们称之为单独的非全局。直接选择IIS的可以配置全局,所以这里要依靠你自己的判断和选择。 打开Url重写工具 在右侧点击添加,然后选择空白规则,然后进行规则的配置。 规则命令如下 这个也是网上一大堆教程最神的地方,很多东西都是缺失的…

    2023年2月21日
    2.0K00
  • 如何通过宝塔面板配置ssl证书

    至于宝塔的安装以及如何安装环境搭建网站,大家可以看我们的另一篇文章: Centos7.6下宝塔安装及资产管理系统部署 基于宝塔面板配置网站ssl证书支持https访问其实很简单,不需要你懂什么技术知识。接下来你跟着我的步骤,就能成功配置网站ssl。 宝塔面板后台设置成功如图所示: 第一步:点击设置 第二步:点击右侧的SSL,选择宝塔SSL,点击申请证书 第三…

    2022年6月14日
    3.1K00
  • 使用Openssl 自签发IP证书

    使用Openssl 自签发IP证书 日常交付项目中,总是有这样的场景,再使用一些融合通讯的业务时,需要HTTPS 环境,那就涉及到SSL 证书的签发 考虑到项目成本的问题,往往都是本地自签发IP 证书使用;使用openssl生成根证书,签发服务端证书,安装根证书使浏览器信任自签证书。 创建证书脚本:ssl.sh 证书脚本内容: 签发证书 签发好的证书 安装根…

    2023年5月26日
    2.0K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信