Centos7删除多余的内核

Linux下可能会存在有多个内核的情况,通过某一内核启动会出现无法登录的情况,这时我们就要选择可以正常登录的内核,成功进入系统后,将多余的内核删除

Centos7删除多余的内核
  1. 检查系统中的内核
[root@localhost ~]# rpm -qa | grep kernel
kernel-3.10.0-1160.66.1.el7.x86_64
kernel-ml-5.18.0-1.el7.elrepo.x86_64
kernel-devel-3.10.0-1160.62.1.el7.x86_64
kernel-devel-3.10.0-327.el7.x86_64
kernel-3.10.0-1160.62.1.el7.x86_64
kernel-headers-3.10.0-1160.66.1.el7.x86_64
kernel-devel-3.10.0-1160.66.1.el7.x86_64
kernel-devel-3.10.0-327.22.2.el7.x86_64
kernel-devel-3.10.0-957.21.3.el7.x86_64
kernel-tools-libs-3.10.0-1160.66.1.el7.x86_64
kernel-tools-3.10.0-1160.66.1.el7.x86_64
  1. 使用yum remove 或rpm -e 删除无用内核
[root@localhost ~]# yum remove kernel-ml-5.18.0-1.el7.elrepo.x86_64

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/5144

赞 (0)
郭靖的头像郭靖
上一篇 2022年6月24日 下午3:42
下一篇 2022年6月25日 下午4:54

相关推荐

  • 在Linux系统内启动某个服务时提示task: Cannot allocate memory该如何处理?

    问题现象 在ECS实例中启动某个服务进程时,系统提示task: Cannot allocate memory错误,如下图所示。 可能原因 可能是系统进程数超限导致。 Linux内核通过内核配置参数kernel.pid_max限制进程的数量,当运行的服务的总进程数超出kernel.pid_max的值时,再创建新进程时系统会报错task: Cannot allo…

    2023年11月14日
    1.4K00
  • Linux 命令神器:lsof

    lsof是系统管理/安全的尤伯工具。将这个工具称之为lsof真实名副其实,因为它是指“列出打开文件(lists openfiles)”。而有一点要切记,在Unix中一切(包括网络套接口)都是文件。 有趣的是,lsof也是有着最多开关的Linux/Unix命令之一。它有那么多的开关,它有许多选项支持使用-和+前缀。 正如你所见,lsof有着实在是令人惊讶的选项…

    2023年3月13日
    1.6K00
  • Route命令详解

    route命令用来显示并设置Linux内核中的网络路由表,route命令设置的路由主要是静态路由。要实现两个不同的子网之间的通信,需要一台连接两个网络的路由器,或者同时位于两个网络的网关来实现。 在Linux系统中设置路由通常是为了解决以下问题:该Linux系统在一个局域网中,局域网中有一个网关,能够让机器访问Internet,那么就需要将这台机器的ip地址…

    2023年4月7日
    1.6K00
  • ubuntu 编译 pyav 报错 libx264 not found

    解决办法:

    2023年9月7日
    1.7K00
  • Nginx优化与防盗链技术

      在当今互联网时代,网站的性能和安全性变得尤为重要。Nginx作为一种高性能的HTTP和反向代理服务器,因其轻量级、高效能和灵活性而被广泛应用于各类网站和应用中。然而,随着互联网流量的不断增长和网络袭击的日益猖獗,如何优化Nginx服务并有效防止盗链成为了每个网站管理员必须面对的重要课题。   Nginx的优化不仅仅是为了提升网站的响应…

    2024年6月27日
    2.5K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信