迁移到新服务器上的PHP网站,使用浏览器访问时提示“不支持MySQL”等信息,如何处理?

问题描述

PHP网站(该网站需使用PHP执行程序代码)迁移到新服务器后,在使用浏览器访问时提示如下任意一种信息。

  • 系统不支持MySQL。
  • PHP不支持MySQL扩展。
  • 其他类似错误信息,示例如下。其他错误..jpeg

问题原因

因为MySQL扩展功能自PHP 5.5.0版本开始被废弃,并且从PHP 7.0.0版本开始被移除,当网站迁移到新服务器时一般会迁移到PHP 7.0.0及以上版本,由于网站迁移后的新服务器的PHP版本过高,网站程序无法再连接MySQL,导致该问题。

您可以使用php -v命令,查看当前服务器的PHP版本,如图所示。查看PHP版本..jpeg

解决方案

您可以在新服务器上安装并运行5.5.0以下版本的PHP源码包,来为网站提供MySQL扩展功能。

说明

本文操作步骤以在CentOS 7.9操作系统为例,具体操作以您实际的操作系统版本为准。

1、登录迁移后云服务器

2、执行如下命令,安装PHP依赖的软件包。

yum install -y gcc gcc-c++ libxml2 libxml2-devel autoconf libjpeg libjpeg-devel libpng libpng-devel freetype freetype-devel zlib zlib-devel glibc glibc-devel glib2 glib2-devel curl curl-devel libxslt-devel openssl-devel

3、执行如下命令,从PHP官网下载PHP 5.5.0及以下版本的源码包。

wget https://www.php.net/distributions/php-5.4.45.tar.gz

4、安装PHP。

执行如下命令,解压下载的源码包。
tar -zxvf php-5.4.45.tar.gz

执行如下命令,进入源码包目录。
cd php-5.4.45

执行如下命令,安装PHP源码包。
./configure --prefix=/usr/local/php5.4.45 --with-curl --with-freetype-dir --with-gd --with-gettext --with-iconv-dir --with-kerberos --with-libdir=lib64 --with-libxml-dir --with-mysql --with-mysqli --with-openssl --with-pcre-regex --with-pdo-mysql --with-pdo-sqlite --with-pear --with-png-dir --with-xmlrpc --with-xsl --with-zlib --enable-fpm --enable-bcmath --enable-libxml --enable-inline-optimization --enable-gd-native-ttf --enable-mbregex --enable-mbstring --enable-opcache --enable-pcntl --enable-sockets --enable-sysvsem --enable-xml --enable-zip

如果回显显示Thank you for using PHP,则表示PHP源码包配置成功,如图所示。

迁移到新服务器上的PHP网站,使用浏览器访问时提示“不支持MySQL”等信息,如何处理?

如果安装过程中缺少某个软件包,会出现相关的报错,您可以根据报错提示安装缺失的软件包,然后再重新安装PHP源码包。

5、执行如下命令,编译并安装PHP。

make && make install

等待PHP安装完成即可。

6、配置PHP运行版本为5.4.45版本。

执行如下命令,进入PHP的安装目录。

cd /usr/local/php5.4.45/etc


执行如下命令,把默认的配置文件复制为php-fpm.conf。

cp php-fpm.conf.default php-fpm.conf


执行如下命令,启动PHP服务。

/usr/local/php5.4.45/sbin/php-fpm 

7、重新访问网站。如果访问成功,该问题解决。

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/10122

赞 (0)
凯影的头像凯影
上一篇 2023年11月16日 下午2:46
下一篇 2023年11月17日 下午2:36

相关推荐

  • NetSet – 自动化网络流量安全增强工具

    NetSet旨在自动执行多个操作,以帮助用户保护网络流量。它还提供了一种通过Tor收集代理和运行实用程序的简便方法。NetSet安装和使用的也是自动配置,该工具主要用于辅助性网络安全任务。 实现了一种按需使用的终端多路复用器,它的会话通过Tor路由网关。通过自动安装和配置DNSCrypt-proxy来保护DNS流量。Tor Wall功能强制所有流量通过Tor…

    2023年10月8日
    2.2K00
  • 安装 Smem – Linux工具 安装条件: 现代内核 (版本号高于 2.6.27) 较新的 Python 版本 (2.4 及以后版本) 可选的 matplotlib 库用于生成图表 对于当今的大多数的 Linux 发行版而言,内核版本和 Python 的版本都能够满足需要,所以仅需要为生成良好的图表安装 matplotlib 库。 RHEL,…

    2023年8月25日
    1.8K00
  • Linux实验案例:构建Samba文件共享服务器

    根据公司的信息化建设要求,公司需要在局域网内部搭建一台文件服务器,便于对数据的集中管理和备份。考虑服务器的运行效率及稳定性、安全性问题,选择在CentOS系统中构建Samba服务器以提供文件资源共享服务。 需求描述 1.在/var/share/目录中建立三个子目录public、training、devel,用途如下。 public目录用于存放公共数据,如公司…

    2024年6月24日
    2.0K00
  • 可以ping通Windows server 2003服务器,无法使用远程桌面登录的解决方法

    Windows系统远程不上有很多种问题,我们最常见的问题就是远程端口访问权限没打开、远程端口防火墙没放行等,所以我们在解决这类问题时,首先就需要查看访问权限、防火墙这两项是否设置正常 如何查看或者修改远程端口 有关于查看和修改远程端口的问题,大家可以去看我们的另外一篇文章,还有一点就是Windows系统更改端口的方法基本都是一致,都是通过修改注册表来实现的:…

    2022年6月20日
    3.4K00
  • 戴尔DELL服务器带外管理iDRAC 7 企业版永久激活教程

    下载 DELL 官方 部署工具 ,并解压。默认是解压到 C 盘根目录。可执行文件 DDDP.exe 默认在路径 C:\dell\drivers\R169189 下。右键 DDDP.exe,以管理员身份运行。图片效果如下: 刻录 U 盘。插入无数据的优盘(注意:此步会格式化 U 盘,因此不要…

    2024年1月16日
    3.3K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信