手把手教你在Centos7.6环境下安装Redis(含详细图文)

1.Linux安装redis

下载:

wget http://download.redis.io/releases/redis-2.8.17.tar.gz

解压源码包

tar xzf redis-2.8.17.tar.gz

解压完成后的目录 redis-2.8.17

安装

# 进入解压后的目录
cd redis-2.8.17
# 编译
make

执行完make命令后,在redis-2.8.17 的 src目录下会出现编译后的 redis 服务程序 redis-server,还有用于测试的客户端程序 redis-cli

启动服务

进入redis-2.8.17 的 src目录执行redis-server

#进入src目录
cd src
#执行
./redis-server
#查看redis进程
ps -ef |grep redis

看到下面这个界面就表示服务端启动成功了

手把手教你在Centos7.6环境下安装Redis(含详细图文)

这种启动方法不能关闭,否则服务就停止了,想从后端开启服务的话需要修改配置文件

vi redis.conf

手把手教你在Centos7.6环境下安装Redis(含详细图文)

执行命令:

./redis-server ../redis.conf

此时就能在后端启动服务

手把手教你在Centos7.6环境下安装Redis(含详细图文)

停止服务

#01 采用kill进程的方式 
kill -9 pid

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/4678

赞 (0)
安屠生的头像安屠生
上一篇 2022年6月14日 下午5:01
下一篇 2022年6月14日 下午5:51

相关推荐

  • mysql误删数据后,从binlog中进行恢复删除数据

    从mysql的logbin中恢复误删数据在一次数据维护过程中,对数据删除时没有提前备份数据,导致数据被删除后无法通过备份文件直接恢复。 1.查找当前操作的binlog状态在myql命令行或者链接工具中,命令查看binlog当前的位置状态和文件信息。 2.flush logs刷新状态 在myql命令行或者链接工具中,使用flush logs命令重新生成新的bi…

    2023年7月29日
    1.4K00
  • 1558 -Column count ot mysql.proc 1s wrong.Expected 20,found 16.Created with MySQL50096, now running 50525. Please use mysql_upgrade to fix this error.

    我在MySQL版本5.5上面创建存储过程的时候就出现了上面的错误。甚至使用show procedure status 查看存储过程都会报上面的错误。 注意操作前先备份!!! 错误原因:是由于你曾经升级过MySQL,或用不同的MySQL版本进行备份迁移恢复。升级和迁移完后未使用mysql_upgrade升级数据结构造成的。 mysql.proc:是MySQL的…

    2023年12月21日
    1.6K00
  • 【mySQL】left join、right join和join的区别

    首先,我们先来建两张表,第一张表命名为kemu,第二张表命名为score: 一、left join顾名思义,就是“左连接”,表1左连接表2,以左为主,表示以表1为主,关联上表2的数据,查出来的结果显示左边的所有数据,然后右边显示的是和左边有交集部分的数据。如下: 结果集: 二、right join “右连接”,表1右连接表2,以右为主,表示以表2为主,关联查…

    2023年8月29日
    2.0K00
  • Mysql备份策略(windows版Mysql)图文详解

    1.建立备份BAT文件脚本 脚本保存未bat文件,放在备份文件夹中。 2.设置定时任务进入定时任务界面,创建任务: 设置触发器,凌晨为比较合适备份时间,系统负载小 操作设置执行刚刚编写的BAT处理脚本 条件设置 最后设置选项 3.灾备编写COPY脚本将备份的文件复制到备份储存盘中BAT脚本内容: 设置定时任务

    2022年8月5日
    1.9K00
  • mysql内存占用过高的问题

    现象:在mysql运行一天之后,发现内存占用量达到总内存的百分之77,且swap被占用百分之50 问题检查如下: 第一步:开启内存使用的监控服务 第二步: 查看正常实例的使用情况 第三步: 查看内存监控表数据 问题解决:         当事件的内存占用是performance_schema过高的话,可以考虑关闭或者减少该事件使用内存的量,操作如下

    2023年7月26日
    1.8K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信