手把手教你在Centos7.6环境下安装Redis(含详细图文)

1.Linux安装redis

下载:

wget http://download.redis.io/releases/redis-2.8.17.tar.gz

解压源码包

tar xzf redis-2.8.17.tar.gz

解压完成后的目录 redis-2.8.17

安装

# 进入解压后的目录
cd redis-2.8.17
# 编译
make

执行完make命令后,在redis-2.8.17 的 src目录下会出现编译后的 redis 服务程序 redis-server,还有用于测试的客户端程序 redis-cli

启动服务

进入redis-2.8.17 的 src目录执行redis-server

#进入src目录
cd src
#执行
./redis-server
#查看redis进程
ps -ef |grep redis

看到下面这个界面就表示服务端启动成功了

手把手教你在Centos7.6环境下安装Redis(含详细图文)

这种启动方法不能关闭,否则服务就停止了,想从后端开启服务的话需要修改配置文件

vi redis.conf

手把手教你在Centos7.6环境下安装Redis(含详细图文)

执行命令:

./redis-server ../redis.conf

此时就能在后端启动服务

手把手教你在Centos7.6环境下安装Redis(含详细图文)

停止服务

#01 采用kill进程的方式 
kill -9 pid

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/4678

赞 (0)
安屠生的头像安屠生
上一篇 2022年6月14日 下午5:01
下一篇 2022年6月14日 下午5:51

相关推荐

  • SqlServer查看默认编码格式

    先使用系统函数SERVERPROPERTY查询当前数据库的编码名称,再使用编码名称通过系统函数COLLATIONPROPERTY查询编码编号,再进行比对。示例如下: 查询比对如下结果:

    2023年2月18日
    1.7K00
  • MySQL配置文件参数详解

    设定MySQL事务是否自动提交,1表示立即提交,0表示需要显式提交。作用范围为全局或会话,可用于配置文件中(但在5.5.8之前的版本中不可用于配置文件),属于动态变量。 设定MySQL服务器是否为存储例程的创建赋予其创建存储例程上的EXECUTE和ALTER ROUTINE权限,默认为1(赋予此两个权限给其创建者)。作用范围为全局。 当MySQL的主线程在短…

    2022年8月16日
    1.4K00
  • Oracle报错:ORA-00257 错误处理

    一、错误描述 使用plsql develop工具登录数据库时,有如下报错: ORA-00257:archiver error. Connect internal only. unitl freed. 二、错误原因 archive log 日志已满 三、处理方法 1.用sys用户登录 2.查看archivlog所在位置 3.VALUE为空时,可用archive…

    2023年3月25日
    1.5K00
  • mysql内存占用过高的问题

    现象:在mysql运行一天之后,发现内存占用量达到总内存的百分之77,且swap被占用百分之50 问题检查如下: 第一步:开启内存使用的监控服务 第二步: 查看正常实例的使用情况 第三步: 查看内存监控表数据 问题解决:         当事件的内存占用是performance_schema过高的话,可以考虑关闭或者减少该事件使用内存的量,操作如下

    2023年7月26日
    1.8K00
  • 数据库压力测试

    一、前言 在前面的压力测试过程中,主要关注的是对接口以及服务器硬件性能进行压力测试,评估请求接口和硬件性能对服务的影响。但是对于多数Web应用来说,整个系统的瓶颈在于数据库。 原因很简单:Web应用中的其他因素,例如网络带宽、负载均衡节点、应用服务器(包括CPU、内存、硬盘、连接数等)、缓存,都很容易通过水平的扩展(俗称加机器)来实现性能的提高。而对于MyS…

    2023年3月21日
    1.3K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信