root用户无法访问Mysql数据库问题的解决

在使用Centos系统远程访问Mysql数据库的时候,系统提示报如下错误:

Access Denied for User 'root'@'localhost' (using password: YES) - No Privileges?

经过验证以下方案可以解决问题:

1.首先停止mysql服务器

sudo service mysqld stop

2.无权限启动mysql服务

sudo service mysqld start --skip-grant-tables

3..登录mysql

mysql

4..重新载入权限

FLUSH PRIVILEGES;
root用户无法访问Mysql数据库问题的解决

5.. 选择系统数据库mysql

use mysql;
root用户无法访问Mysql数据库问题的解决

6..查询系统表user中的用户

select host,user,authentication_string from user;
root用户无法访问Mysql数据库问题的解决

7.向root用户赋值权限

GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' WITH GRANT OPTION;

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/9067

(0)
郭靖的头像郭靖
上一篇 2023年6月19日 下午4:22
下一篇 2023年6月21日 下午5:23

相关推荐

  • MySQL常见错误代码

    MySQL常见错误代码及代码说明 1005:创建表失败 1006:创建数据库失败 1007:数据库已存在,创建数据库失败<=================可以忽略 1008:数据库不存在,删除数据库失败<=================可以忽略 1009:不能删除数据库文件导致删除数据库失败 1010:不能删除数据目录导致删除数据库失败 10…

    2023年3月28日
    1.4K00
  • Elasticsearch Query DSL查询入门

    Query DSL又叫查询表达式,是一种非常灵活又富有表现力的查询语言,采用JSON接口的方式实现丰富的查询,并使你的查询语句更灵活、更精确、更易读且易调试 查询与过滤 Elasticsearch(以下简称ES)中的数据检索分为两种情况:查询和过滤。 Query查询会对检索结果进行评分,注重的点是匹配程度,例如检索“运维咖啡吧”与文档的标题有多匹配,计算的是…

    2023年5月26日
    1.3K00
  • sqlserver数据库出现可疑错误修复方法

    1、主数据库出现可疑修复方法:sql 第一种方法:数据库 当数据库发生这种操做故障时,能够按以下操做步骤可处理此要领,打开数据库里的Sql查询编辑器窗口,运行如下的命令: 编辑器 ?修改数据库为紧急模式sqlserver  ALTER DATABASE 数据库名 SET EMERGENCYspa ?使数据库变为单用户模式日志  …

    2023年2月18日
    1.7K00
  • 索引–加快MySQL查询

    1.索引的描述 索引在MySQL中也叫做”键”,保存着数据位置的信息; 其作用是为了加快数据库的查询速度; 实际上,索引也是一张表,该表保存了主键与索引字段,并指向实体表的记录。 2.索引的使用 添加索引 #案例 主键会自动创建索引,外键约束也会自动创建索引 删除索引 #案例 添加联合索引 语法 联合索引又叫复合索引,是MySQL的I…

    2022年8月17日
    1.8K00
  • 无法作为数据库主体执行,因为主体 “dbo“ 不存在、无法模拟这种类型的主体,或您没有所需的权限

    问题描述: 最近正在测试数据库复制,想删除发布服务器的发布数据库时,突然提示这个:无法作为数据库主体执行,因为主体 “dbo” 不存在、无法模拟这种类型的主体,或您没有所需的权限。已将数据库上下文更改为 “AdventureWorks2008R2”。 (Microsoft SQL Server,错误: 15517) 原因分析: 用附件文件和组的方法的还原数据…

    2023年2月18日
    1.6K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信