Discuz! X 3.4, 更新PHP7.4后无法打开uc_server的解决方案!

页面报错:
Deprecated: Array and string offset access syntax with curly braces is deprecated in/www/wwwroot/***/uc_server/admin.php on line53

出现报错原因:

PHP7.4不再支持使用大括号访问数组以及字符串的偏移

Discuz! X 3.4, 更新PHP7.4后无法打开uc_server的解决方案!

将53行修改为:

if(method_exists($control, $method) && $a[0] != '_') {

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/9420

赞 (0)
郭靖的头像郭靖
上一篇 2023年7月31日 下午4:38
下一篇 2023年8月1日 下午4:34

相关推荐

  • Discuz! Database Error的解决办法

    原因一:数据库表太大 比如mysql数据库的表内容太大,超过10G就有可能会影响discuz论坛的运行。 这种情况可以通过对数据库分表的方法来解决。 原因二:数据库配置错误 有时候可能是主机搬家、数据库搬家等,造成数据库信息填写错误,或旧数据库信息没有及时更新等,比如数据库用户名、密码、数据库表填写错误等。 可以修正一下相关数据库信息即可,可以找到confi…

    2023年2月21日
    2.0K00
  • Tomcat日志切割工具 logrotate

    Tomcat日志切割工具 logrotate 在我们生产环境中经常遇到tomcat log清理的问题,曾经做过实验通过重定向的方式把日志清空,但是发现日志tomcat里面的catalina.out不输出日志了。这时候我们可以考虑一下日志管理工具Logrotate 一、日志工具Logrotate简介 二、Logrotate运行机制 系统会定时运行logrota…

    2023年3月24日
    1.5K00
  • 如何在 Kubernetes Pod 中快速注入环境变量及优先级问题

    1. Kubernetes Pod 引用环境变量的几种方式 1.1 直接 Key/Value 1.2 从 Secret 引用 有两种方式引用 Secret 中的变量: 1.3 从 ConfigMap 引用 有两种方式引用 ConfigMap 中的变量: 2. 变量引用的优先级 从源码中可以看到的实现逻辑是,会初始化一个 Map 存放环境变量,然后按照如下步骤…

    2023年8月14日
    2.0K00
  • LNMP黄金架构的搭建

    LNMP组合工作流程 LNMP工作流是用户通过浏览器输入域名访问Nginx web服务,Nginx判断请求是静态请求则由Nginx返回给用户。如果是动态请求(如.php结尾),那么Nginx会将该请求通过FastCGI接口发送给PHP引擎(php-fpm进程)进行解析,如果该动态请求需要读取mysql数据库,php会继续向后读取数据库,最终Nginx将获取的…

    2022年7月7日
    2.2K00
  • IIS php网站 无法在<fastCGI>应用程序配置中找到<handler> scriptProcessor

    打开后会发现,根目录里面会自动生成的多出来的这个文件【web.config】直接删除掉,然后再去刷新一下你的页面就可以正常显示了 改你的路径。

    2023年4月6日
    1.9K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信