Discuz! X 3.4, 更新PHP7.4后无法打开uc_server的解决方案!

页面报错:
Deprecated: Array and string offset access syntax with curly braces is deprecated in/www/wwwroot/***/uc_server/admin.php on line53

出现报错原因:

PHP7.4不再支持使用大括号访问数组以及字符串的偏移

Discuz! X 3.4, 更新PHP7.4后无法打开uc_server的解决方案!

将53行修改为:

if(method_exists($control, $method) && $a[0] != '_') {

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/9420

(0)
杰斯的头像杰斯
上一篇 2023年7月31日 下午4:38
下一篇 2023年8月1日 下午4:34

相关推荐

  • 用 Nginx 禁止国外 IP 访问我的网站

    看了下 Nginx 的访问日志,发现每天有好多国外的 IP 地址来访问我的网站,并且访问的内容基本上都是恶意的。因此我决定禁止国外 IP 来访问我的网站。 想要实现这个功能有很多方法,下面我就来介绍基于 Nginx 的 ngx_http_geoip2 模块来禁止国外 IP 访问网站。 ①安装 geoip2 扩展依赖: ②下载 ngx_http_geoip2_…

    2023年4月24日
    25100
  • 如何在 Kubernetes Pod 中快速注入环境变量及优先级问题

    1. Kubernetes Pod 引用环境变量的几种方式 1.1 直接 Key/Value 1.2 从 Secret 引用 有两种方式引用 Secret 中的变量: 1.3 从 ConfigMap 引用 有两种方式引用 ConfigMap 中的变量: 2. 变量引用的优先级 从源码中可以看到的实现逻辑是,会初始化一个 Map 存放环境变量,然后按照如下步骤…

    2023年8月14日
    28600
  • 解决Composer Installing dependencies from lock file

    1、问题描述 2、原因 这是因为不匹配composer.json要求的版本。提示我的PHP 7版本太高,不符合composer.json需要的版本,但是在PHP 7下应该也是可以运行的,composer可以设置忽略版本匹配。 3、解决方案 composer install –ignore-platform-reqs 或者 composer update -…

    2023年2月14日
    49800
  • sl认证 Processing, The CA is processing your order, please just wait.

    执行操作: 如果ssl认证报如下错误 Processing, The CA is processing your order, please just wait. (29/30) 请添加 注意:如果是centos系统一定要关闭防火墙:systemctl stop firewalld.service

    2023年3月11日
    29700
  • 修改IDEA占用的内存大小

    首先找到 配置VM的文件,打开IDEA ➡ 顶部菜单栏 ➡ Help (帮助)➡ Edit Custom VM Options(编辑自定义VM编辑) 详细如下图: 修改下面这几部分就行了: 我改成最大2048M=2G了,这回应该够用了。修改完后 Ctrl + S 保存,记住保存!!! 重启下IDEA,OK了

    2023年9月13日
    25400

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信