Docker安装部署Redis数据库

通过Docker部署Redis,比起我们自己编译安装的方式,会更加方便容易管理。今天就来简单分享一下使用Docker部署Redis数据库。

1,拉取镜像

通过下列命令:

docker pull redis

2,创建数据卷

通常,类似于MySQL,Redis作为数据库,我们最好还是需要将其配置和数据等等挂载到数据卷以持久化到宿主机。

仍然是使用具名挂载的方式方便管理。

docker volume create redis-config
docker volume create redis-data

这样就创建了两个数据卷分别是存放配置文件和数据,大家也可以自行命名。

3,创建并编写配置文件

先进入到配置文件的数据卷目录,可以通过docker volume inspect命令查看数据卷的位置:

docker volume inspect redis-config
Docker安装部署Redis数据库

进入目录后创建名为redis.conf的文件,并加入如下内容:

requirepass 12345678
dir /data

这里设置了密码为12345678,设定了数据文件存放目录为/data,这些配置都可以自定义,更多配置可以参考这篇博客。

4,创建并启动容器

执行下列命令:

docker run -id --name=redis -v redis-config:/usr/local/etc/redis -v redis-data:/data -p 6379:6379 -e LANG=C.UTF-8 redis su -l root -c "redis-server /usr/local/etc/redis/redis.conf"

上述参数如下:

  • -v 指定数据卷,可见将容器内/usr/local/etc/redis挂载至了数据卷redis-config,将容器内/data挂载至数据卷redis-data,可见这里挂载数据卷的容器内路径和我们上述预先写的配置文件中对应的路径是要一致的
  • -p 用于暴露端口
  • -e 用于指定容器内环境变量,设置容器的语言环境变量LANG值为C.UTF-8,这个最好是要设置,否则容器内默认是英文环境,使得Redis可能无法存放中文内容

末尾是启动命令,单独拿出来看一下:

su -l root -c "redis-server /usr/local/etc/redis/redis.conf"

意思是在容器内以root身份运行redis-server并指定了配置文件位置。

之所以要以root身份运行,是因为防止其没有权限将数据写入到磁盘。也可见最后指定的配置文件路径,和前面-v挂载的配置文件数据卷的容器内路径一致,这里好理解,但是要注意,如果你是自定义别的路径与文件名就需要在-v挂载时和最后启动指定配置时做一下变化了。

最后,就可以使用客户端连接服务器上的Redis了!

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/6596

赞 (0)
郭靖的头像郭靖
上一篇 2023年1月10日 下午2:20
下一篇 2023年1月12日 下午5:28

相关推荐

  • linux centOS虚拟机出现entering emergency mode解决方案

    1、centos打开之后出现这个问题,迟迟打不开 按他的操作输入journalctl之后输入shift+g到日志最后查看报错发现是xfs(dm-0有问题) 输入xfs_repair -v -L /dev/dm-0因此修复 /dev/dm-0就可以了 -L 选项指定强制日志清零,强制xfs_repair将日志归零,即使它包含脏数据(元数据更改)。 #重启虚拟机…

    2024年1月11日
    1.8K00
  • Centos7上安装Zabbix6.0

    1、先安装依赖,mysql,nginx,php mysql安装,mysql版本要8.0及以上 Nginx安装 PHP 部署 启动后即可在浏览器通过ip访问到测试页,如果访问失败,检查ip80端口是否开放 2、zabbix安装 选择版本 看别人的资料说6.0在centos7系统只能通过source安装,所以到官网选择source安装,选择TLS长久维护版 安装…

    2023年5月31日
    1.5K00
  • Linux parted 分区命令详解

    一、概述通常我们用的比较多的分区工具是fdisk命令,但由于fdisk只支持MBR分区,MBR分区表最大支撑2T的磁盘,所以无法划分大于2T的分区。而parted工具可以划分单个分区大于2T的GPT格式的分区,也可以划分普通的MBR分区。 parted命令是由GNU组织开发的一款功能强大的磁盘分区和分区大小调整工具。GPT格式的磁盘相当于原来MBR磁盘中原来…

    2023年8月1日
    1.7K00
  • 在linux中访问网站提示“Nginx 502 bad gateway”错误如何处理?

    问题原因 “Nginx 502 Bad Gateway”错误表示访问请求的php-cgi进程已经开始执行,但是由于读取资源失败等原因没有执行完毕,导致php-cgi进程终止。 常见的问题原因如下: 解决方案 您可以参考如下操作进行逐一排查。 说明 本文中/usr/local/php/etc/php-fpm.conf、/usr/local/php/etc/ph…

    2023年11月16日
    1.5K00
  • Linux Top 命令指南

    top 命令允许用户监视 Linux 上的进程和系统资源使用情况,它是系统管理员工具箱中最有用的工具之一,并且在每个发行版中都预装了它。与 ps 等其他命令不同,它是交互式的,我们可以浏览进程列表、终止进程,等等。本文中,我们将了解如何使用 top 命令。 Getting started top 命令非常简单,只需要在终端中输入 top 即可。top 指令将…

    2022年12月13日
    1.5K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信