Windows下安装Nginx错误总结

Windows下安装Nginx错误总结

别问我为啥非要在Windows上按照Nginx,问的话,回答就是:有这个需求

1:CreateFile()“xxxxx” failed (3: The system cannot find the path specified)

产生原因:创建文件xxxx异常了。大多数情况就是因为:安装目录中存在中文或者是空格

比如凯哥的就是因为存在空格。凯哥第一次安装目录:d:\Program Files (x86)\nginx1.8

就是因为这个目录存在了空格导致的。

修改:D:\study\nginx-1.8.1

这样启动就解决了。

如果配置文件使用了include命令的话,windows系统默认文件分隔符是“\”,建议修改成“/”。如下:

include D:/data/nginxdomainconfig/vhost/nginx/*.conf;

2:nginx “nginx could not build the server_names_hash”解决方法

Windows下安装Nginx错误总结

解决方法:  在配置文件的http{}段增加一行配置  server_names_hash_bucket_size 64;  如果64还不够,那么就按32的倍数往上加。  下面是在中文wiki上摘抄的一段说明:  保存服务器名字的hash表是由指令 server_names_hash_max_size 和 server_names_hash_bucket_size所控制的。参数hash bucket size总是等于hash表的大小,并且是一路处理器缓存大小的倍数。在减少了在内存中的存取次数后,使在处理器中加速查找hash表键值成为可能。如果 hash bucket size等于一路处理器缓存的大小,那么在查找键的时候,最坏的情况下在内存中查找的次数为2。第一次是确定存储单元的地址,第二次是在存储单元中查找键值。因此,如果Nginx给出需要增大 hash max size 或 hash bucket size的提示,那么首要的是增大前一个参数的大小.

然后重新加载,执行命令:nginx.exe -s rolad。

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/11640

赞 (0)
凯影的头像凯影
上一篇 2024年5月11日 下午2:56
下一篇 2024年5月13日 下午2:56

相关推荐

  • rsync综合备份

    一.先看需求 客户端需求:1.客户端每天凌晨1点在服务器本地打包备份(/etc目录和/var/log目录)2.客户端备份的数据必须存放至以 “主机名ip地址当前时间” 命名的目录中3.客户端最后通过rsync推送本地已经打包好的备份文件至backup服务器4.客户端服务器本地保留最近7天的数据,避免浪费磁盘空间 服务端需求:1.服务端…

    2023年12月11日
    1.7K00
  • Linux实验案例:构建Samba文件共享服务器

    根据公司的信息化建设要求,公司需要在局域网内部搭建一台文件服务器,便于对数据的集中管理和备份。考虑服务器的运行效率及稳定性、安全性问题,选择在CentOS系统中构建Samba服务器以提供文件资源共享服务。 需求描述 1.在/var/share/目录中建立三个子目录public、training、devel,用途如下。 public目录用于存放公共数据,如公司…

    2024年6月24日
    2.0K00
  • Linux 大日志文件按时间查询与分割处理

    按时间查看日志 日志文件有40G: 大文件分割 split命令操作 按文件行数分割 catalina.out 按50000分割一个文件: 按文件大小分割 除了按照行数切割之外,split还支持通过文件大小进行切割,通过指定-b参数指定文件大小进行切割,文件大小单位支持K, M, G, T, P, E, Z,如下以切割为500M演示文件切割过程。

    2024年1月9日
    1.8K00
  • 提高终端生产力神器 – tmux

    tmux github 一键安装 centos 系列可以直接用 yum debian 系列可以直接用 apt-get 编译安装 编译 libevent 编译 tmux 编译 tmux 还需要用到 ncurses 验证 tmux 是不是可用 如果出现报错:tmux: error while loading shared libraries: libevent_…

    2023年11月10日
    1.6K00
  • 在 Linux 上以 All-in-One 模式安装 KubeSphere

    步骤 1:准备 Linux 机器 若要以 All-in-One 模式进行安装,您仅需参考以下对机器硬件和操作系统的要求准备一台主机。 硬件推荐配置 操作系统 最低配置 Ubuntu 16.04, 18.04, 20.04, 22.04 2 核 CPU,4 GB 内存,40 GB 磁盘空间 Debian Bus…

    2023年4月18日
    1.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信