Windows下安装Nginx错误总结

Windows下安装Nginx错误总结

别问我为啥非要在Windows上按照Nginx,问的话,回答就是:有这个需求

1:CreateFile()“xxxxx” failed (3: The system cannot find the path specified)

产生原因:创建文件xxxx异常了。大多数情况就是因为:安装目录中存在中文或者是空格

比如凯哥的就是因为存在空格。凯哥第一次安装目录:d:\Program Files (x86)\nginx1.8

就是因为这个目录存在了空格导致的。

修改:D:\study\nginx-1.8.1

这样启动就解决了。

如果配置文件使用了include命令的话,windows系统默认文件分隔符是“\”,建议修改成“/”。如下:

include D:/data/nginxdomainconfig/vhost/nginx/*.conf;

2:nginx “nginx could not build the server_names_hash”解决方法

Windows下安装Nginx错误总结

解决方法:  在配置文件的http{}段增加一行配置  server_names_hash_bucket_size 64;  如果64还不够,那么就按32的倍数往上加。  下面是在中文wiki上摘抄的一段说明:  保存服务器名字的hash表是由指令 server_names_hash_max_size 和 server_names_hash_bucket_size所控制的。参数hash bucket size总是等于hash表的大小,并且是一路处理器缓存大小的倍数。在减少了在内存中的存取次数后,使在处理器中加速查找hash表键值成为可能。如果 hash bucket size等于一路处理器缓存的大小,那么在查找键的时候,最坏的情况下在内存中查找的次数为2。第一次是确定存储单元的地址,第二次是在存储单元中查找键值。因此,如果Nginx给出需要增大 hash max size 或 hash bucket size的提示,那么首要的是增大前一个参数的大小.

然后重新加载,执行命令:nginx.exe -s rolad。

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/11640

(0)
凯影的头像凯影
上一篇 2024年5月11日 下午2:56
下一篇 2024年5月13日 下午2:56

相关推荐

  • Docker部署MinIO对象存储服务器结合Cpolar实现远程访问

    前言MinIO是一个开源的对象存储服务器,可以在各种环境中运行,例如本地、Docker容器、Kubernetes集群等。它兼容Amazon S3 API,因此可以与现有的S3工具和库无缝集成。MinIO的设计目标是高性能、高可用性和可扩展性。它可以在分布式模式下运行,以满足不同规模的存储需求。 MinIO是一个开源的软件,可以免费使用,还可以在普通硬件上运行…

    2023年12月20日
    1.6K00
  • Asciinema:你的所有操作都将被录制

    asciinema 是一款开源免费的终端录制工具,它可以将命令行输入输出的任何内容加上时间保存在文件中,同时还提供方法在终端或者web浏览器中进行回放 asciinema的录制和播放都是基于文本的,相比传统的video有很多好处,例如录制文件体积小,在播放的过程中可以暂停复制其中的文本内容等等 同时asciinema还提供了一个网站,你如果愿意还可…

    2023年5月23日
    1.5K00
  • Centos7中搭建WebDav的服务

    一 什么是WebDAV 百度百科的定义:WebDAV (Web-based Distributed Authoring and Versioning) 一种基于 HTTP 1.1协议的通信协议。它扩展了HTTP 1.1,在GET、POST、HEAD等几个HTTP标准方法以外添加了一些新的方法,使应用程序Web Server直接读写,并支持写文件锁定(Lock…

    2023年3月9日
    1.9K00
  • Linux 时间同步 Chrony

    Chrony是NTP(Network Time Protocol,网络时间协议,服务器时间同步的一种协议)的另一种实现,与ntpd不同,它可以更快且更准确地同步系统时钟,最大程度的减少时间和频率误差。 在CentOS6中,默认是使用ntpd来同步时间的,但ntpd同步时间并不理想,有可能需要数小时来同步时间。而且ntp也已经很老了。所以在Centos7中换成…

    2023年1月6日
    2.1K00
  • 使用 B VPS 中转 A VPS 流量

    引言 由于某些不可抗力原因, 所处网络环境无法访问 A VPS, 因此 增加 能访问到的 B VPS 来中转流量到 A VPS me –x-> A VPS me <—-> B VPS <—-> A VPS 非内网穿透需求, A VPS 有公网ip, 可被公网直接发现 和使用某些客户端 配合 Cloudflare…

    2024年6月28日
    3.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信