Windows下安装Nginx错误总结

Windows下安装Nginx错误总结

别问我为啥非要在Windows上按照Nginx,问的话,回答就是:有这个需求

1:CreateFile()“xxxxx” failed (3: The system cannot find the path specified)

产生原因:创建文件xxxx异常了。大多数情况就是因为:安装目录中存在中文或者是空格

比如凯哥的就是因为存在空格。凯哥第一次安装目录:d:\Program Files (x86)\nginx1.8

就是因为这个目录存在了空格导致的。

修改:D:\study\nginx-1.8.1

这样启动就解决了。

如果配置文件使用了include命令的话,windows系统默认文件分隔符是“\”,建议修改成“/”。如下:

include D:/data/nginxdomainconfig/vhost/nginx/*.conf;

2:nginx “nginx could not build the server_names_hash”解决方法

Windows下安装Nginx错误总结

解决方法:  在配置文件的http{}段增加一行配置  server_names_hash_bucket_size 64;  如果64还不够,那么就按32的倍数往上加。  下面是在中文wiki上摘抄的一段说明:  保存服务器名字的hash表是由指令 server_names_hash_max_size 和 server_names_hash_bucket_size所控制的。参数hash bucket size总是等于hash表的大小,并且是一路处理器缓存大小的倍数。在减少了在内存中的存取次数后,使在处理器中加速查找hash表键值成为可能。如果 hash bucket size等于一路处理器缓存的大小,那么在查找键的时候,最坏的情况下在内存中查找的次数为2。第一次是确定存储单元的地址,第二次是在存储单元中查找键值。因此,如果Nginx给出需要增大 hash max size 或 hash bucket size的提示,那么首要的是增大前一个参数的大小.

然后重新加载,执行命令:nginx.exe -s rolad。

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/11640

赞 (0)
凯影的头像凯影
上一篇 2024年5月11日 下午2:56
下一篇 2024年5月13日 下午2:56

相关推荐

  • Windows配置磁盘监控

    通过pushgateway的方式,主动推送监控数据给prometheus。 由于windows平台的诸多限制,导致推送比较艰难。有两种方法完成监控。 1.通过python等语言,做推送脚本。 2.曲线救国就是把监控数据scp发给Linux机器。再通过linux做二次加工推给pushgateway。 window server上配置环境 1.首先判断服务器磁盘…

    2022年11月25日
    1.8K00
  • 在 Kubernetes 上最小化安装 KubeSphere

    除了在 Linux 机器上安装 KubeSphere 之外,您还可以将其直接部署在现有的 Kubernetes 集群上。本快速入门指南将引导您完成在 Kubernetes 上最小化安装 KubeSphere 的一般性步骤。 准备工作 备注 部署 KubeSphere 确保您的机器满足安装的前提条件之后,可以按照以下步骤安装 KubeSphere。 执行以下命…

    2023年4月18日
    1.6K00
  • LAMP环境下部署DiscuzQ

    一、安装Apachae yum安装Apache,并设置开机自启动 在网页浏览器输入ip地址,查看Apache是否正常 二、安装配置 MariaDB 执行以下命令,查看系统中是否已安装 MariaDB。 rpm -qa | grep -i mariadb       返回结果类似如下内容,则表示已存在 MariaDB。 &nbsp…

    2022年12月6日
    2.0K00
  • 此站点的连接不安全,使用不受支持的协议。ERR_SSL_VERSION_OR_CIPHER_MISMATCH(不支持的协议 客户端和服务器不支持常用的 SSL 协议版本或密码套件。)

    如图所示报错 一、解决方法一1.Microsoft Edge浏览器→点击右上角的三个点→选择设置 2.选择外观→打开Internet Explorer 模式(IE 模式)按钮 3.打开Microsoft Edge浏览器→输入自己要访问的IP地址或者是链接→回车访问→点击右上角的IE图标(在 Internet Explorer 模式下的重新加载选项卡) 4.访…

    2023年7月25日
    4.4K00
  • centos 7 NTP 内网时间定时同步

    一、环境 二、ntp安装服务 server服务器配置: client服务器配置:(如果有多台client服务器,亦可如此配置) 四、启动NTP服务&开机启动设置(包括server服务器和client服务器) 五、server服务器防火墙配置 六、client服务器手动从server服务器进行时间同步 在server服务器上执行date命令,查看时间 …

    2023年6月14日
    1.6K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信