Windows下安装Nginx错误总结

Windows下安装Nginx错误总结

别问我为啥非要在Windows上按照Nginx,问的话,回答就是:有这个需求

1:CreateFile()“xxxxx” failed (3: The system cannot find the path specified)

产生原因:创建文件xxxx异常了。大多数情况就是因为:安装目录中存在中文或者是空格

比如凯哥的就是因为存在空格。凯哥第一次安装目录:d:\Program Files (x86)\nginx1.8

就是因为这个目录存在了空格导致的。

修改:D:\study\nginx-1.8.1

这样启动就解决了。

如果配置文件使用了include命令的话,windows系统默认文件分隔符是“\”,建议修改成“/”。如下:

include D:/data/nginxdomainconfig/vhost/nginx/*.conf;

2:nginx “nginx could not build the server_names_hash”解决方法

Windows下安装Nginx错误总结

解决方法:  在配置文件的http{}段增加一行配置  server_names_hash_bucket_size 64;  如果64还不够,那么就按32的倍数往上加。  下面是在中文wiki上摘抄的一段说明:  保存服务器名字的hash表是由指令 server_names_hash_max_size 和 server_names_hash_bucket_size所控制的。参数hash bucket size总是等于hash表的大小,并且是一路处理器缓存大小的倍数。在减少了在内存中的存取次数后,使在处理器中加速查找hash表键值成为可能。如果 hash bucket size等于一路处理器缓存的大小,那么在查找键的时候,最坏的情况下在内存中查找的次数为2。第一次是确定存储单元的地址,第二次是在存储单元中查找键值。因此,如果Nginx给出需要增大 hash max size 或 hash bucket size的提示,那么首要的是增大前一个参数的大小.

然后重新加载,执行命令:nginx.exe -s rolad。

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/11640

赞 (0)
凯影的头像凯影
上一篇 2024年5月11日 下午2:56
下一篇 2024年5月13日 下午2:56

相关推荐

  • Linux缓冲区的理解

    一、FIFE 可以看到对过程重定向后结果发生了改变,C接口的函数printf,fprintf,fputs都被打印了两次;而系统接口write前后只被打印了一次,为什么呢?肯定和fork有关! fork会创建子进程。在创建子进程的时候,数据会被处理成两份,父子进程发生写时拷贝,我们进行printf调用数据的时候,数据写到显示器外设上,就不属于父进程了,数据没被…

    2023年4月10日
    1.5K00
  • ubuntu20.04 删除linux中软raid的方法

    取消软件 RAID 可能涉及到几个步骤,具体取决于你的操作系统和使用的软件。在大多数 Linux 系统中,mdadm 是用于管理软件 RAID 的常见工具。以下是在 Linux 中取消软件 RAID 的一般步骤: 请注意:在执行这些步骤之前,请确保你已经备份了所有重要数据,因为取消 RAID 可能会导致数据丢失。 查看当前 RAID 状态: 使用以下命令查看…

    2023年11月24日
    2.2K00
  • Ubuntu 启用root账户并开启远程登录

    1.启用root账户 修改root用户密码,输入下方命令后,还需要输入当前普通用户的密码进行身份验证,然后修改root用户的新密码 sudo passwd root 2、开启远程登录 执行下方命令后开启root用户的远程登录 此时就能使用root账户成功登录了

    2022年6月11日
    2.2K00
  • DELL idrac7 企业版永久激活教程

    下载 DELL idrac7 激活工具 DELL 官方部署工具(EW5099A0.EXE) ,并解压。默认是解压到 C 盘根目录。可执行文件 DDDP.exe 默认在路径 C:\dell\drivers\R169189 下。右键 DDDP.exe,以管理员身份运行。图片效果如下: 刻录 U 盘。插入无数据的优盘(注意:此步会格式化 U 盘,因此不要用有数据的…

    2023年2月17日
    6.8K40
  • Ubuntu系统如何配置镜像源

    我们在使用Linux系统时,一般来说都是需要配置一个源地址才能直接使用下载的命令来安装软件的,若你购买的是云服务器,正常来讲是服务器厂商配置好了源的,但是也不缺乏有少量的机器源会出现问题,导致安装软件不成功,如下图所示,那么我们就需要手动去配置了 第一步:替换原有的源 第二步:安装证书 如果安装失败,重新安装即可

    2022年6月14日
    1.9K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信