Mysql5.5中文乱码问题

img
  1. 查看MySQL的字符集
show variables like '%char%'; 

发现有部分不是utf-8

img

一(推荐,本人实验有用)

修改MySQL配置文件,来到mysql安装目录,找到my.ini文件(可能没有此文件,没有就自己建一个,本人就是没有该文件)

Mysql5.5中文乱码问题
  • 若有my.ini文件 进去之后,在三个地方增加配置

第一个

[client]
default-character-set=utf8

第二个

[mysql]
default-character-set=utf8

第三个

[mysqld]
character-set-client-handshake = FALSE
character-set-server = utf8
collation-server = utf8_unicode_ci
init_connect='SET NAMES utf8'
  • 若没有my.ini文件,则添加一个,内容为:
[client]
default-character-set=utf8
[mysql]
default-character-set=utf8
[mysqld]
character-set-client-handshake = FALSE
character-set-server = utf8
character_set_filesystem = utf8
collation-server = utf8_unicode_ci
init_connect='SET NAMES utf8'

注意!!! 记得重启mysql服务 此电脑——>管理——>服务和应用程序——>服务——>mysql服务——>重新启动

img
  1. 解决办法二(不推荐,本人实验没用,每次改完都会被还原)

查看MySQL的字符集

show variables like '%char%';

修改mysql数据表字符集编码的命令

SET character_set_client='utf8'; 
SET character_set_connection='utf8';
SET character_set_database='utf8';
SET character_set_filesystem='utf8';
SET character_set_results='utf8';
SET character_set_server='utf8';
SET character_set_system='utf8';

重启mysql服务 此电脑——>管理——>服务和应用程序——>服务——>mysql服务——>重新启动

  1. 其他情况,如果上面mysql设置好了,任然乱码那就可能是其他问题了,可能是数据库管理工具(如Navicat)的问题,也可能是代码编辑环境的问题(比如eclipse里的环境设置)imgimg
  2. 希望帮助到你,解决中文乱码问题

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/5961

赞 (0)
安屠生的头像安屠生
上一篇 2022年8月21日 下午1:39
下一篇 2022年8月21日 下午5:25

相关推荐

  • MySQL服务器开启SSL加密功能

    MySQL服务器开启SSL加密功能 我们知道,MySQL5.7之前版本,安全性做的并不够好,比如安装时生成的root空密码账号、存在任何用户都能连接上的test库等,导致数据库存在较大的安全隐患。好在5.7版本对以上问题进行了一一修复。与此同时,MySQL 5.7版本还提供了更为简单SSL安全访问配置,且默认连接就采用SSL的加密方式,这让数据库的安全性提高…

    2023年12月18日
    1.9K00
  • MySQL 中 DELETE 语句中可以使用别名么?

    某天,正按照业务的要求删除不需要的数据,在执行 DELETE 语句时,竟然出现了报错! 背景 某天,正按照业务的要求删除不需要的数据,在执行 DELETE 语句时,竟然出现了报错(MySQL 数据库版本 5.7.34): 这就有点奇怪了,因为我在执行删除语句之前,执行过同样条件的 SELECT 语句,只是把其中的 select * 换成了…

    2023年11月22日
    1.9K00
  • 数据库慢查询及其优化

    我们经常会谈到数据库慢查询。那么什么是数据库慢查询以及导致数据库慢查询的常见原因,以及对应的解决方法。 1、什么是数据库慢查询 数据库慢查询,就是查询时间超过了我们设定的时间的语句。可以通过语句查看设定的时间: 默认的设定时间是10秒,也可以通过下面这个语句修改默认的设定时间: 2、MySQL 慢查询的相关参数解释 3、慢查询日志配置 默认情况下slow_q…

    2022年6月11日
    1.7K00
  • docker容器无法访问宿主机数据库

    今天用docker部署一个web服务时遇到总是连不上宿主机mysql数据库的问题,报SQLSTATE[HY000] [2002] Connection refused,经过测试,宿主机用相同配置可以连上,登入docker容器内就连不上,初步判断容器内通过localhost或127.0.0.1是连不上宿主机的。具体原因和解决方法如下: 原因: 今天用docke…

    2023年8月9日
    2.3K00
  • Oracle用户密码过期的处理方法

    受影响版本:Oracle11g以上版本。 导致密码消失的原因:Oracle 11g中默认的DEFAULT概要文件中口令有效期PASSWORD_LIFE_TIME默认值为180天。 当以客户端登陆Oracle提示ORA-28002,则基本可以确定登陆帐号已过有效期,使用具有DBA权限的帐号重置该帐号密码即可。 解决方法: 以下步骤以具有DBA权限用户操作 1.…

    2024年5月9日
    1.9K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信