如何处理CentOS Failed to load SELinux policy

CentOS 7在启动时,卡在进度条界面一直进不去系统,如下图所示:

如何处理CentOS Failed to load SELinux policy

我们可以通过按键盘的左右方向键,可以看到提示“Failed to load SELinux policy.”,这就是造成系统一直卡住无法正常启动的原因。

如何处理CentOS Failed to load SELinux policy

原因

是因为没有正确修改系统的selinux的配置,导致系统在启动时报selinux的错误

解决方案

第一步:先重启CentOS7操作系统,在出现开机界面时按下向上或者向下方向键,以便开机界面停留下。然后选择第一行,按字母 e 进行编辑

如何处理CentOS Failed to load SELinux policy

第二步:进入编辑界面(其实是 CentOS 7 的启动选项),按向下方向键定位到“linux16”开头的一行,再按向右方向键找到“LANG=zh_CN.UTF-8”

如何处理CentOS Failed to load SELinux policy

第三步:在末尾以空格间隔后加上 selinux=0

如何处理CentOS Failed to load SELinux policy

第四步:按下Ctrl + x 键,就可以进入登录界面

如何处理CentOS Failed to load SELinux policy

第五步:以 root 用户登录成功后,执行以下命令,主要调整以下两行

1)SELINUX=disabled

2)SELINUXTYPE=targeted

[root@localhost ~]# vi /etc/selinux/config

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of three two values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected.
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

最后,wq保存配置,然后再重启系统就可以正常启动了

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/4764

赞 (0)
郭靖的头像郭靖
上一篇 2022年6月15日 下午5:19
下一篇 2022年6月15日 下午6:33

相关推荐

  • linux中为cp和mv命令添加进度条

    安装高级复制补丁以在 Linux 中向 cp 和 mv 命令添加进度条 cp 和 mv 命令是GNU coreutils. 所以你需要GNU coreutils从这里下载最新的。 现在两个新的补丁的二进制文件即cp与mv将在中创建coreutils-9.0/src的文件夹。只需将它们复制到你的 $PATH 中,如下所示: 该cpg和mvg命令有现在进度条的功…

    2023年6月16日
    1.6K00
  • 通过配置hosts.allow和hosts.deny限制登陆

    我们通常只对管理员开放SSH登录,那我们就可以禁用不必要的IP,而只开放管理员可能使用到的IP段。 /etc/hosts.allow和/etc/hosts.deny两个文件是控制远程访问设置的,通过他可以允许或者拒绝某个ip或者ip段的客户访问linux的某项服务。 我们通常只对管理员开放SSH登录,那我们就可以禁用不必要的IP,而只开放管理员可能使用到的I…

    2022年11月15日
    2.4K00
  • 通过 Linux 命令行连接远程 Windows 系统

    安装 xfreerdp 在使用 xfreerdp 之前,您需要安装它。在大多数 Linux 发行版中,您可以使用包管理器来执行此操作。 在 Ubuntu / Debian 和 Linux Mint 上,运行以下命令 基于 RHEL 的发行版,如 Rocky Linux、AlmaLinux 和 Fedora,运行以下命令 使用 xfreerdp 远程连接 Wi…

    2023年9月20日
    1.8K00
  • 如何保持esxi修改的策略在重启后依然生效

    vmkernel使用的是内存文件系统,配置、日志、补丁都保存在内存中。而 开机引导使用的p_w_picpaths 则保存在/bootbank和 /altbootbank目录下。这也是为什么 esxi 系统不需要在主机上安装,也可以直接引导起来的原因,它会把远程的镜像直接安装到内存中。     如何将配置保存,在 esxi 系统重启后依然有效,我查了不少文档,…

    2023年3月14日
    1.7K00
  • CentOS 7 磁盘挂载教程

    mount命令是经常会使用到的命令,它用于挂载Linux系统外的文件 进行挂载操作后,用户便可以在挂载目录中使用硬盘资源了。默认情况下Linux系统并不会像Windows系统那样自动的挂载光盘和U盘设备,需要自行完成。 语法 语法格式:mount [参数] [设备] [挂载点] 常用参数 -t 指定文件系统,即挂载类型 -l 显示已加载的文件系统列表 -h …

    2022年6月9日
    3.9K10

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信