如何处理CentOS Failed to load SELinux policy

CentOS 7在启动时,卡在进度条界面一直进不去系统,如下图所示:

如何处理CentOS Failed to load SELinux policy

我们可以通过按键盘的左右方向键,可以看到提示“Failed to load SELinux policy.”,这就是造成系统一直卡住无法正常启动的原因。

如何处理CentOS Failed to load SELinux policy

原因

是因为没有正确修改系统的selinux的配置,导致系统在启动时报selinux的错误

解决方案

第一步:先重启CentOS7操作系统,在出现开机界面时按下向上或者向下方向键,以便开机界面停留下。然后选择第一行,按字母 e 进行编辑

如何处理CentOS Failed to load SELinux policy

第二步:进入编辑界面(其实是 CentOS 7 的启动选项),按向下方向键定位到“linux16”开头的一行,再按向右方向键找到“LANG=zh_CN.UTF-8”

如何处理CentOS Failed to load SELinux policy

第三步:在末尾以空格间隔后加上 selinux=0

如何处理CentOS Failed to load SELinux policy

第四步:按下Ctrl + x 键,就可以进入登录界面

如何处理CentOS Failed to load SELinux policy

第五步:以 root 用户登录成功后,执行以下命令,主要调整以下两行

1)SELINUX=disabled

2)SELINUXTYPE=targeted

[root@localhost ~]# vi /etc/selinux/config

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of three two values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected.
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

最后,wq保存配置,然后再重启系统就可以正常启动了

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/4764

赞 (0)
郭靖的头像郭靖
上一篇 2022年6月15日 下午5:19
下一篇 2022年6月15日 下午6:33

相关推荐

  • Ubuntu系统如何配置镜像源

    我们在使用Linux系统时,一般来说都是需要配置一个源地址才能直接使用下载的命令来安装软件的,若你购买的是云服务器,正常来讲是服务器厂商配置好了源的,但是也不缺乏有少量的机器源会出现问题,导致安装软件不成功,如下图所示,那么我们就需要手动去配置了 第一步:替换原有的源 第二步:安装证书 如果安装失败,重新安装即可

    2022年6月14日
    2.0K00
  • Win10彻底永久关闭自动更新

    在使用Win10系统的过程中,经常会遇到系统提示自动更新的问题,时不时就要更新,非常烦人。其实我们可以关闭自动更新功能,这样就不会收到系统提示了。下面小编就给大家分享一下Win10彻底永久关闭自动更新的方法。 一、禁用Windows Update服务   1、同时按下键盘 Win + R,打开运行对话框,然后输入命令 services.msc ,点击下方的“…

    2024年6月11日
    2.2K00
  • ubuntu修改默认文件权限umask

    在Ubuntu中,umask是一个内置的shell命令,用于确定新创建文件和目录的默认权限。umask值是一个三位或四位的八进制数。这个值被从全权限(即777)中减去,以得到新文件或目录的默认权限。 要临时修改umask值,你可以在命令行中直接输入umask命令,后面跟上你想要的值。例如,要将umask设置为022(这将使新文件的默认权限为755,新目录的默…

    2023年10月16日
    2.0K00
  • Ansible 连接主机显示报错的处理方案

    一、在ansible安装完毕后一般需要以SSH的方式连接到需要进行管理的目标主机,一开始遇到了如下问题: 原因分析:没有在ansible管理节点(即安装ansible的节点)上添加目标节点(即需要管理的节点)的ssh认证信息。 解决步骤:1:管理节点生成SSH-KEY 成功后在~/.ssh/路径下将生成ssh密钥文件:id_rsa及id_rsa.pub2:添…

    2023年9月28日
    1.8K00
  • Centos7中搭建WebDav的服务

    一 什么是WebDAV 百度百科的定义:WebDAV (Web-based Distributed Authoring and Versioning) 一种基于 HTTP 1.1协议的通信协议。它扩展了HTTP 1.1,在GET、POST、HEAD等几个HTTP标准方法以外添加了一些新的方法,使应用程序Web Server直接读写,并支持写文件锁定(Lock…

    2023年3月9日
    2.0K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信