Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)

问题

  • 客户反应过来网站打开是出现错误,错误现象如下:
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 尝试登录phpMyadmin链接,显示如下错误
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 连接数据库相关表格显示以下错误
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)

解决方法

  • 经过判断,是服务器系统盘满了
  • 找到我们的脚本,运行后清理c盘(https://www.cnaaa.net/archives/4743
  • 还可以设置一个定时任务,定期清理,防止再遇到这种问题,打开”计算机管理“,找到“任务计划程序”,点击右边“创建基本任务”
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 添加名称描述
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 设置触发器时间和具体时间
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 选择定时任务执行的操作,这里选启动程序,然后选择脚本
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 完成后右击定时程序,选择“更改用户或组”
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 选择“高级”
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 选择“立即查找”,找到system,确认
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
  • 修改后,下面的运行账户会变更
Mysql报错:1030, ‘Got error 28 from storage engine‘的解决方法(附相关解决脚本)
相关文件下载地址
©下载资源版权归作者所有;本站所有资源均来源于网络,仅供学习使用,请支持正版!

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/4715

(0)
郭靖的头像郭靖
上一篇 2022年6月14日 下午5:51
下一篇 2022年6月15日 下午2:08

相关推荐

  • 构建SQL自动审核系统

    Inception Inception是一个开源的Mysql自动化工具,具有SQL审核、执行、回滚等实用的功能,由国内大神基于mysql源码开发,可以很明确的,详细的,准确的审核Mysql的SQL语句,工作模式与Mysql完全相同,可以直接使用mysql客户端来连接。但遗憾的是2年前已停止更新,不过兼容大部分的mysql版本,仍然是开源SQL审核工具的翘楚。…

    2023年1月17日
    1.7K00
  • 关于MySQL的lock wait timeout exceeded解决方案

    一、问题抛出 在做查询语句时,MySQL 抛出了这样的异常: 即Lock wait timeout exceeded; try restarting transaction的异常,错误提示的意思,很明显,是因为这条语句被锁住了,所以释放这个锁。 二、解决方案 我们可以通过到information_schema 中来进行查找被锁的语句。 解释:inf…

    2023年8月31日
    1.6K00
  • Sql Server数据库显示中文乱码的解决方案

    .数据库中文乱码原因 1. 一种情况是实际生产环境的电脑并不支持中文语言,但是数据库的数据表里面,有些说明字段需要用中文显示,这个时候就出现了乱码了 2. 另外一种情况是,安装数据库的时候,使用的是默认的编码规则。这个时候如果电脑本身就不支持中文语言。然后数据库表里面录入中文,也会出现乱码。支持中文的电脑,安装使用默认的选项,数据表录入中文,好像没有出现过乱…

    2023年2月18日
    2.0K00
  • MySQL 如何避免克隆失败后再次初始化

    在我之前关于 CLONE INSTANCE 命令的博客文章《MySQL 克隆插件不是你的备份》中,我提到使用选项 DATA DIRECTORY 有助于避免在克隆操作失败时需要从头开始重新初始化副本和克隆相关设置的情况。 MySQL 克隆插件简化了新副本的配置,但不会简化失败后的服务器恢复,除非您准备从头开始重新安装 M…

    2023年10月23日
    1.9K00
  • 数据库报错:Cause com.mysql.jdbc.exceptions.jdbc4.CommunicationsException:Communications link failure

    原因1.因为SSL连接原因(大部分人的原因)因为MySQL在高版本需要指明是否进行SSL连接。有可能你 pom 文件引入的 MySQL 依赖版本是MySQL5.7及以上 这些的时候,你就需要指定SSL连接,如果你不知道,默认就是开启,所以就会出现上面的错误。 2.因为数据库连接超时原因当数据库重启或数据库空闲连接超过设置的最大timemout时间,数据库会强…

    2023年8月1日
    1.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信