Sql Server数据库显示中文乱码的解决方案

.数据库中文乱码原因

1. 一种情况是实际生产环境的电脑并不支持中文语言,但是数据库的数据表里面,有些说明字段需要用中文显示,这个时候就出现了乱码了

2. 另外一种情况是,安装数据库的时候,使用的是默认的编码规则。这个时候如果电脑本身就不支持中文语言。然后数据库表里面录入中文,也会出现乱码。支持中文的电脑,安装使用默认的选项,数据表录入中文,好像没有出现过乱码问题。

Sql Server数据库显示中文乱码的解决方案

2. 如何解决

2.1 快速的解决方案就是,建库的时候,指定 Chinese_PRC_CS_AI_WS (中文简体)编码类型。

Sql Server数据库显示中文乱码的解决方案

 2.2 接着,数据库建立好之后,先选中该库,右键-属性,点击选项-排序规则,看看是不是 Chinese_PRC_CS_AI_WS (中文简体)编码。如果不是就再次更改,直到成功为止。

Sql Server数据库显示中文乱码的解决方案

 2.4 接着,再重新建立数据库表,这个时候录入中文,就没有乱码了

Sql Server数据库显示中文乱码的解决方案

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/7274

赞 (0)
郭靖的头像郭靖
上一篇 2023年2月18日 下午1:57
下一篇 2023年2月18日 下午4:21

相关推荐

  • 构建SQL自动审核系统

    Inception Inception是一个开源的Mysql自动化工具,具有SQL审核、执行、回滚等实用的功能,由国内大神基于mysql源码开发,可以很明确的,详细的,准确的审核Mysql的SQL语句,工作模式与Mysql完全相同,可以直接使用mysql客户端来连接。但遗憾的是2年前已停止更新,不过兼容大部分的mysql版本,仍然是开源SQL审核工具的翘楚。…

    2023年1月17日
    1.8K00
  • 解决远程连接MySQL报错:2003 – Can‘t connect to MySQL server on ‘X.X.X.X‘ (10060 “Unknown error“)问题

    问题先看报错: 2003 – Can’t connect to MySQL server on ‘X.X.X’ (10060 “Unknown error”)。 意思是服务器远程连接出错:未知错误。 解决方案:遇到这个问题,首先想到的是权限不够。那咱就给它赋权。 首先登录MySQL数据库:mysql -u用户名 -p密码; 然后:use mysq…

    2023年7月27日
    1.7K00
  • Oracle用户密码过期的处理方法

    受影响版本:Oracle11g以上版本。 导致密码消失的原因:Oracle 11g中默认的DEFAULT概要文件中口令有效期PASSWORD_LIFE_TIME默认值为180天。 当以客户端登陆Oracle提示ORA-28002,则基本可以确定登陆帐号已过有效期,使用具有DBA权限的帐号重置该帐号密码即可。 解决方法: 以下步骤以具有DBA权限用户操作 1.…

    2024年5月9日
    1.9K00
  • sql server 日志文件过大的处理方法

    选择文件–日志-限制大小为500m

    2023年6月13日
    1.6K00
  • mysql innodb临时表btmp1文件太大

    某日生产环境(数据库实例)告警,磁盘使用率过高! 检查发现是由于mysql的data目录的ibtmp1文件太大,达到了30GB 一、ibtmp1文件是干嘛的? 就是用来存放临时表查询时的数据。 二、ibtmp1增长的原因是什么?主要与SQL有关,尤其是大量的分组聚合,排序,join查询SQL.通常如下情况会造成iptmp1上涨: 查询语句会先查询temp_t…

    2023年12月18日
    2.0K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信