Sql Server数据库显示中文乱码的解决方案

.数据库中文乱码原因

1. 一种情况是实际生产环境的电脑并不支持中文语言,但是数据库的数据表里面,有些说明字段需要用中文显示,这个时候就出现了乱码了

2. 另外一种情况是,安装数据库的时候,使用的是默认的编码规则。这个时候如果电脑本身就不支持中文语言。然后数据库表里面录入中文,也会出现乱码。支持中文的电脑,安装使用默认的选项,数据表录入中文,好像没有出现过乱码问题。

Sql Server数据库显示中文乱码的解决方案

2. 如何解决

2.1 快速的解决方案就是,建库的时候,指定 Chinese_PRC_CS_AI_WS (中文简体)编码类型。

Sql Server数据库显示中文乱码的解决方案

 2.2 接着,数据库建立好之后,先选中该库,右键-属性,点击选项-排序规则,看看是不是 Chinese_PRC_CS_AI_WS (中文简体)编码。如果不是就再次更改,直到成功为止。

Sql Server数据库显示中文乱码的解决方案

 2.4 接着,再重新建立数据库表,这个时候录入中文,就没有乱码了

Sql Server数据库显示中文乱码的解决方案

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/7274

赞 (0)
郭靖的头像郭靖
上一篇 2023年2月18日 下午1:57
下一篇 2023年2月18日 下午4:21

相关推荐

  • MySQL 中 DELETE 语句中可以使用别名么?

    某天,正按照业务的要求删除不需要的数据,在执行 DELETE 语句时,竟然出现了报错! 背景 某天,正按照业务的要求删除不需要的数据,在执行 DELETE 语句时,竟然出现了报错(MySQL 数据库版本 5.7.34): 这就有点奇怪了,因为我在执行删除语句之前,执行过同样条件的 SELECT 语句,只是把其中的 select * 换成了…

    2023年11月22日
    1.9K00
  • Oracle用户密码过期的处理方法

    受影响版本:Oracle11g以上版本。 导致密码消失的原因:Oracle 11g中默认的DEFAULT概要文件中口令有效期PASSWORD_LIFE_TIME默认值为180天。 当以客户端登陆Oracle提示ORA-28002,则基本可以确定登陆帐号已过有效期,使用具有DBA权限的帐号重置该帐号密码即可。 解决方法: 以下步骤以具有DBA权限用户操作 1.…

    2024年5月9日
    1.9K00
  • MySQL配置文件参数详解

    设定MySQL事务是否自动提交,1表示立即提交,0表示需要显式提交。作用范围为全局或会话,可用于配置文件中(但在5.5.8之前的版本中不可用于配置文件),属于动态变量。 设定MySQL服务器是否为存储例程的创建赋予其创建存储例程上的EXECUTE和ALTER ROUTINE权限,默认为1(赋予此两个权限给其创建者)。作用范围为全局。 当MySQL的主线程在短…

    2022年8月16日
    1.4K00
  • Redis 缓存雪崩、缓存穿透、缓存击穿、缓存预热

    缓存雪崩 定义 缓存雪崩是指在短时间内,有大量缓存同时过期,导致大量的请求直接查询数据库,从而对数据库造成了巨大的压力,严重情况下可能会导致数据库宕机的情况叫做缓存雪崩。 正常情况下执行过程: 缓存雪崩下执行过程: 可以看到,当缓存失效时,大量请求直接绕过 Redis 去请求数据库,导致会对数据库造成很大压力。 解决 加锁排队 加锁排队可以起到缓冲的作用,防…

    2022年11月17日
    1.5K00
  • Sql Server2005 如何导出数据库数据

    Sql Server2005数据库数据导出两种方式 第一种,数据库数据直接备份,右键点击需要备份的库,打开任务,打开备份,然后记一下数据库备份文件位置,直接点击确定即可成功,注意修改文件路径可能会提示文件无权限 第二种方式 打开本地服务,停止Sql server服务,然后去复制需要的ldf与mdf文件

    2022年12月16日
    1.6K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信