Sql Server数据库显示中文乱码的解决方案

.数据库中文乱码原因

1. 一种情况是实际生产环境的电脑并不支持中文语言,但是数据库的数据表里面,有些说明字段需要用中文显示,这个时候就出现了乱码了

2. 另外一种情况是,安装数据库的时候,使用的是默认的编码规则。这个时候如果电脑本身就不支持中文语言。然后数据库表里面录入中文,也会出现乱码。支持中文的电脑,安装使用默认的选项,数据表录入中文,好像没有出现过乱码问题。

Sql Server数据库显示中文乱码的解决方案

2. 如何解决

2.1 快速的解决方案就是,建库的时候,指定 Chinese_PRC_CS_AI_WS (中文简体)编码类型。

Sql Server数据库显示中文乱码的解决方案

 2.2 接着,数据库建立好之后,先选中该库,右键-属性,点击选项-排序规则,看看是不是 Chinese_PRC_CS_AI_WS (中文简体)编码。如果不是就再次更改,直到成功为止。

Sql Server数据库显示中文乱码的解决方案

 2.4 接着,再重新建立数据库表,这个时候录入中文,就没有乱码了

Sql Server数据库显示中文乱码的解决方案

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/7274

(0)
郭靖的头像郭靖
上一篇 2023年2月18日 下午1:57
下一篇 2023年2月18日 下午4:21

相关推荐

  • MySQL配置文件参数详解

    设定MySQL事务是否自动提交,1表示立即提交,0表示需要显式提交。作用范围为全局或会话,可用于配置文件中(但在5.5.8之前的版本中不可用于配置文件),属于动态变量。 设定MySQL服务器是否为存储例程的创建赋予其创建存储例程上的EXECUTE和ALTER ROUTINE权限,默认为1(赋予此两个权限给其创建者)。作用范围为全局。 当MySQL的主线程在短…

    2022年8月16日
    1.4K00
  • docker容器无法访问宿主机数据库

    今天用docker部署一个web服务时遇到总是连不上宿主机mysql数据库的问题,报SQLSTATE[HY000] [2002] Connection refused,经过测试,宿主机用相同配置可以连上,登入docker容器内就连不上,初步判断容器内通过localhost或127.0.0.1是连不上宿主机的。具体原因和解决方法如下: 原因: 今天用docke…

    2023年8月9日
    2.2K00
  • 解决远程连接MySQL报错:2003 – Can‘t connect to MySQL server on ‘X.X.X.X‘ (10060 “Unknown error“)问题

    问题先看报错: 2003 – Can’t connect to MySQL server on ‘X.X.X’ (10060 “Unknown error”)。 意思是服务器远程连接出错:未知错误。 解决方案:遇到这个问题,首先想到的是权限不够。那咱就给它赋权。 首先登录MySQL数据库:mysql -u用户名 -p密码; 然后:use mysq…

    2023年7月27日
    1.7K00
  • MySQL 用户管理 – 添加用户、授权、删除用户

    不要直接使用 root 用户管理应用数据 添加用户 以root用户登录数据库,运行以下命令: 上面的命令创建了用户 zhangsan, 密码是 zhangsan. 在 mysql.user 表里可以查看到新增用户的信息: 授权 命令格式: grant privilegesCode on dbName.tableName to username@host id…

    2022年12月21日
    1.6K00
  • MySQL:想实现sql语句进行批量删除数据库或表,而引发的熬夜探究

    因为在自测过程中,创建了很多数据库,一个个手动删除属实有点对不起程序员这个身份,那么有没有简单的sql语句操作来进行批量删除数据库呢?于是便有了本篇文章 思路了解到数据库或表的信息都保存在MySQL内置的 information_schema数据库的SCHEMATA表中,因此是否可以通过like查询information_schema中的相关表名,拼接SQL…

    2023年12月21日
    1.8K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信