让你配置linux 路由,你该怎么配置

如下图所示有两个网络,分别是0网段和2网段,路由器1组成0网段,路由器2从路由器一种分出一个2网段

让你配置linux 路由,你该怎么配置

如果要在不同网段直接通讯,需要添加路由,linux添加路由命令如下:

route [add|del] [-net|-host] target [netmask Nm] [gw Gw] [[dev] If]

add : 添加一条路由规则

del : 删除一条路由规则

-net : 目的地址是一个网络

-host : 目的地址是一个主机

target : 目的网络或主机

netmask : 目的地址的网络掩码

gw : 路由数据包通过的网关

dev : 为路由指定的网络接口

1、添加主机路由

  如果想192.168.2.10主机 ping通192.168.0.8主机,则需要经过路由器2,就要在192.168.2.10的主机上添加一条到192.168.0.8的路由,添加命令如下:

  route add -host 192.168.0.8  gw 192.168.2.1 dev eth0

  这条命令的意思是访问192.168.0.8的主机消息都从192.168.2.1端口转发。用route命令查看一下添加的路由

让你配置linux 路由,你该怎么配置
Destination目标网络或目标主机。Destination 为 default(0.0.0.0)时,表示这个是默认网关,所有数据都发到这个网关(这里是 10.139.128.1
Gateway网关地址,0.0.0.0 表示当前记录对应的 Destination 跟本机在同一个网段,通信时不需要经过网关(同一个局域网内2台主机通信不需要经过网关)
GenmaskDestination 字段的网络掩码,Destination 是主机时需要设置为 255.255.255.255,是默认路由时会设置为 0.0.0.0
Flags标志U – Up表示有效G – Gateway表示连接路由,若无这个字段表示直连目的地址H – Host表示目标是具体主机,而不是网段R 恢复动态路由产生的表项D 由路由的后台程序动态地安装M 由路由的后台程序修改! 拒绝路由
 Metric 路由距离,到达指定网络所需的中转数,是大型局域网和广域网设置所必需的 (不在Linux内核中使用。)
 Ref 路由项引用次数 (不在Linux内核中使用。)
 Use 此路由项被路由软件查找的次数
 Iface 网卡名字,例如 eth0;要去往这个网段需要使用哪一个网络接口。也就是eth0这张网卡

   第一条路由信息的意思就是访问主机192.168.0.8的信息都从192.168.2.1网关转发。

  若要删除这条路由只需执行:route del 192.168.0.8 

2、添加网络路由

  第一种添加主机路由的方式只能访问到一台目录主机,如果192.168.2.10要访问0网段的所有主机的话把0网段主机都添加一遍显然很麻烦,通过添加网络路由的方式,只要在192.168.0.10主机上添加一条0网段的网络路由即可,添加命令如下:

  route add -net 192.168.0.0 netmask 255.255.255.0 gw 192.168.2.1 dev eth0

  这个目标是网络,所以需要设置子网掩码,用route命令查看一下添加的网络路由

让你配置linux 路由,你该怎么配置

这条路由表示访问0网段的消息都从192.168.2.1网关转发

  删除网络路由:route del -net 192.168.0.0/24 gw 192.168.2.1

3、添加默认路由

  如果2网段主机想访问其他所以网段的网络,只需要添加默认路由即可:route add default gw 192.168.2.1 dev eth0

让你配置linux 路由,你该怎么配置

  默认路由的意思是所有访问非2网段的信息都从192.168.2.1转发

  删除默认路由:route del default

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/12124

(0)
凯影的头像凯影
上一篇 2024年6月17日 下午3:29
下一篇 2024年6月18日 下午2:53

相关推荐

  • 在Linux系统内启动某个服务时提示task: Cannot allocate memory该如何处理?

    问题现象 在ECS实例中启动某个服务进程时,系统提示task: Cannot allocate memory错误,如下图所示。 可能原因 可能是系统进程数超限导致。 Linux内核通过内核配置参数kernel.pid_max限制进程的数量,当运行的服务的总进程数超出kernel.pid_max的值时,再创建新进程时系统会报错task: Cannot allo…

    2023年11月14日
    1.4K00
  • Nginx常见502错误提示原因和解决方法

    常见的Nginx 502 Bad Gateway解决办法如下: Nginx 502错误情况1: 网站的访问量大,而php-cgi的进程数偏少。 针对这种情况的502错误,只需增加php-cgi的进程数。具体就是修改/usr/local/php/etc/php-fpm.conf 文件,将其中的max_children值适当增加。这个数据要依据你的VPS或独立服…

    2022年6月21日
    1.7K00
  • MySQL 如何使用离线模式维护服务器

    离线模式 作为 DBA,最常见的任务之一就是批量处理 MySQL 服务的启停或其他一些活动。在停止 MySQL 服务前,我们可能需要检查是否有活动连接;如果有,我们可能需要把它们全部杀死。通常,我们使用 pt-kill 杀死应用连接或使用 SELECT 语句查询准备杀死语句。例如: MySQL 有一个名为 offline_mode 的变量…

    2023年10月20日
    1.5K00
  • 使用 B VPS 中转 A VPS 流量

    引言 由于某些不可抗力原因, 所处网络环境无法访问 A VPS, 因此 增加 能访问到的 B VPS 来中转流量到 A VPS me –x-> A VPS me <—-> B VPS <—-> A VPS 非内网穿透需求, A VPS 有公网ip, 可被公网直接发现 和使用某些客户端 配合 Cloudflare…

    2024年6月28日
    3.4K00
  • 在Linux中执行yum命令失败,提示“HTTP Error 404 -Not Found Trying other mirror”错误怎么办?

    问题描述 在Linux系统的ECS实例中执行yum命令(如yum -y install XXX、yum list、yum search XXX等)失败,出现类似如下错误信息。 问题原因 出现该问题可能有以下原因: 解决方案 切换CentOS 6/8的源地址 CentOS 6与CentOS 8操作系统版本结束了生命周期(EOL),Linux社区已不再维护该操作…

    2023年11月28日
    1.3K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信