pve 虚拟机关机未成功被锁定,如何解决

有时我们在回滚快照时,因为某一些错误并不能正确回滚,导致LXC容器被锁定,导致我们无法进入系统,只需要在Proxmox VE下输入解锁命令即可解锁。

例如我有一个LXC容器Ubuntu系统,因为快照回滚失败被锁定,容器加了一个锁并变为rollback状态,此时此容器无法打开。

pve 虚拟机关机未成功被锁定,如何解决

只需要在Proxmox VE命令行窗口输入解锁命令即可解锁。

pct unlock 101

101为要解锁的容器ID。
pve 虚拟机关机未成功被锁定,如何解决

如果是虚拟机被锁定则输入以下命令解锁虚拟机。同样后面的数字换成你的虚拟机ID。

qm unlock 101

然后就可以通过命令行操作虚拟机了

#查看集群资源状况
#pvesh get /cluster/resources
pve 虚拟机关机未成功被锁定,如何解决
#取得虚拟机当前状态
#pvesh get /nodes/<节点id>/qemu/<虚拟机id>/status/current
#pvesh get /nodes/www/qemu/107/status/current
pve 虚拟机关机未成功被锁定,如何解决
#关闭虚拟机
#pvesh create /nodes/<节点id>/qemu/<虚拟机id>/status/stop
#pvesh create /nodes/www/qemu/107/status/stop

#启动虚拟机
#pvesh create /nodes/<节点id>/qemu/<虚拟机id>/status/start
#pvesh create /nodes/www/qemu/107/status/start
pve 虚拟机关机未成功被锁定,如何解决

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/12097

赞 (0)
凯影的头像凯影
上一篇 2024年6月14日 下午3:59
下一篇 2024年6月17日 下午3:29

相关推荐

  • Docker安装部署Redis数据库

    通过Docker部署Redis,比起我们自己编译安装的方式,会更加方便容易管理。今天就来简单分享一下使用Docker部署Redis数据库。 1,拉取镜像 通过下列命令: 2,创建数据卷 通常,类似于MySQL,Redis作为数据库,我们最好还是需要将其配置和数据等等挂载到数据卷以持久化到宿主机。 仍然是使用具名挂载的方式方便管理。 这样就创建了两个数据卷分别…

    2023年1月11日
    1.6K00
  • linux centOS虚拟机出现entering emergency mode解决方案

    1、centos打开之后出现这个问题,迟迟打不开 按他的操作输入journalctl之后输入shift+g到日志最后查看报错发现是xfs(dm-0有问题) 输入xfs_repair -v -L /dev/dm-0因此修复 /dev/dm-0就可以了 -L 选项指定强制日志清零,强制xfs_repair将日志归零,即使它包含脏数据(元数据更改)。 #重启虚拟机…

    2024年1月11日
    1.8K00
  • Ceph集群日常使用命令

    一、Ceph 集群服务维护 之前文章说了一下ceph的安装,安装其实比较简单,但是后续维护起来我们需要知道常用的维护命令 如果我们机器上osd、mon、rgw等服务都安装在一个节点,可以通过下面的命令直接管理所有服务 ceph target allowing to start/stop all ceph*@.service instances at once…

    2023年4月19日
    1.6K00
  • 爽了!免费的SSL,还能自动续期!

    兄弟👬🏻,当你手里有不少域名,每个域名又配置子域名,那么ssl将是一笔不小的费用。当然各个云厂商,也都有提供免费的ssl证书,但这里有一个问题,就是基本都不提供免费的泛域名证书(免费20个单域名证书),比如 x.gaga.plus、b.gaga.plus 这就要申请2个域名证书了!并且3个月就过期,一年就折腾这,都能折腾哭😭!那咋办? 像我这样做技术分享的,…

    2024年6月4日
    1.6K00
  • 在Linux系统内启动某个服务时提示task: Cannot allocate memory该如何处理?

    问题现象 在ECS实例中启动某个服务进程时,系统提示task: Cannot allocate memory错误,如下图所示。 可能原因 可能是系统进程数超限导致。 Linux内核通过内核配置参数kernel.pid_max限制进程的数量,当运行的服务的总进程数超出kernel.pid_max的值时,再创建新进程时系统会报错task: Cannot allo…

    2023年11月14日
    1.5K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信