pve 虚拟机关机未成功被锁定,如何解决

有时我们在回滚快照时,因为某一些错误并不能正确回滚,导致LXC容器被锁定,导致我们无法进入系统,只需要在Proxmox VE下输入解锁命令即可解锁。

例如我有一个LXC容器Ubuntu系统,因为快照回滚失败被锁定,容器加了一个锁并变为rollback状态,此时此容器无法打开。

pve 虚拟机关机未成功被锁定,如何解决

只需要在Proxmox VE命令行窗口输入解锁命令即可解锁。

pct unlock 101

101为要解锁的容器ID。
pve 虚拟机关机未成功被锁定,如何解决

如果是虚拟机被锁定则输入以下命令解锁虚拟机。同样后面的数字换成你的虚拟机ID。

qm unlock 101

然后就可以通过命令行操作虚拟机了

#查看集群资源状况
#pvesh get /cluster/resources
pve 虚拟机关机未成功被锁定,如何解决
#取得虚拟机当前状态
#pvesh get /nodes/<节点id>/qemu/<虚拟机id>/status/current
#pvesh get /nodes/www/qemu/107/status/current
pve 虚拟机关机未成功被锁定,如何解决
#关闭虚拟机
#pvesh create /nodes/<节点id>/qemu/<虚拟机id>/status/stop
#pvesh create /nodes/www/qemu/107/status/stop

#启动虚拟机
#pvesh create /nodes/<节点id>/qemu/<虚拟机id>/status/start
#pvesh create /nodes/www/qemu/107/status/start
pve 虚拟机关机未成功被锁定,如何解决

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/12097

赞 (0)
凯影的头像凯影
上一篇 2024年6月14日 下午3:59
下一篇 2024年6月17日 下午3:29

相关推荐

  • Nginx 代理多个服务器(多个server方式)

    1.介绍 1.1 背景介绍 如果每台linux服务器只运行了一个小网站,那么人气低,流量小的草根站长需要承担高额的服务器租赁费,也造成了硬件资源浪费。 虚拟主机就是将一台服务器分割成多个“虚拟服务器”,每个站点使用各自的硬盘空间,由于省资源,省钱,众多网站都使用虚拟主机来部署网站。 虚拟主机的概念就是在web服务里的一个独立的网站站点,这个站点对应独立的域名…

    2022年6月23日
    2.2K00
  • Linux SSH 登录失败多少次禁止该IP访问 防止暴力破解

    Linux 系统SSH 登录失败的内容会记录到/var/log/secure文件,通过查找关键字 Failed,可以定位到这些异常的IP地址,比如: 比如这里,明显这个IP地址在进行SSH 扫描,不断的更换端口和用户进行暴力测试。 在Linux里面有两个相关的文件: /etc/hosts.allow: 允许哪些IP访问主机 /etc/hosts.deny 禁…

    2023年3月1日
    1.8K00
  • 关于编码你必须知道的知识和技巧

    乱码问题是所有运维职业生涯中都会遇到的问题,本篇文章带你探究背后的原理以及解决的技巧 字符编码 我们知道计算机只认识二进制数据,其他格式的数据都需要转换成二进制才能被计算机处理,也就是说我们在计算机上看到的文本、视频、可执行程序等格式的文件,最终都会转换成二进制数据交给计算机处理 计算机中最小的数据单位是bit,也叫二进制位,每一个bit都有0和1两种状态,…

    2023年1月16日
    1.7K00
  • 通过远程桌面连接Windows系统的ECS实例时,提示“远程桌面连接已断开”错误怎么办?

    问题描述 通过远程桌面连接Windows系统的ECS实例时失败,并提示“远程桌面连接已断开”错误,具体显示如下图。 问题原因 通过VNC登录Windows实例,进入事件查看器查看系统日志,提示“终端服务器安全层在协议流中检测到错误,并已取消客户端连接”的错误,该问题可能是由于ECS实例的注册表中Certificate子键损坏导致的。 解决方案 本文操作以Wi…

    2023年11月15日
    1.8K00
  • 远程连接Windows Server 2003实例后在服务器上执行操作时速度缓慢,如何处理?

    问题描述 远程连接Windows Server 2003实例时,使用VNC登录服务器正常,但是使用其他远程连接方式登录服务器时,打开程序和浏览网站速度缓慢。 问题原因 网卡的Offload.Tx.LSO参数为开启状态导致该问题。 解决方案 您可以根据实际情况选择如下任意一种方案处理该问题,具体如下: 将网卡的Offload.Tx.LSO参数更改为Disabl…

    2023年11月17日
    1.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信