在linux中访问网站提示“Nginx 502 bad gateway”错误如何处理?

问题原因

“Nginx 502 Bad Gateway”错误表示访问请求的php-cgi进程已经开始执行,但是由于读取资源失败等原因没有执行完毕,导致php-cgi进程终止。

常见的问题原因如下:

解决方案

您可以参考如下操作进行逐一排查。

说明

本文中/usr/local/php/etc/php-fpm.conf/usr/local/php/etc/php.ini/etc/nginx.conf等配置文件需要根据安装环境不同来更换路径,请以您的实际部署安装的软件路径为准。

磁盘空间不足

如果访问网站时,直接提示“Nginx 502 Bad Gateway”错误,可能是ECS实例的磁盘空间不足导致。您需要执行如下步骤进行排查:

  1. 远程登录ECS实例。具体操作,请参见连接方式概述。
  2. 执行df -h命令,查看是否磁盘空间是否充足。
    • 如果磁盘空间充足,则该问题不是由于磁盘空间问题导致。
    • 如果磁盘空间不足,则您需要扩容
    df -h

php-cgi进程数不够用

如果在已安装Nginx且可以正常访问网站的环境中,运行一段时间才后出现“Nginx 502 Bad Gateway”错误,则可能是php-cgi进程数不够用导致。

此时,您需要修改/usr/local/php/etc/php-fpm.conf配置文件,将文件中pm.max_children参数的值调高,即增加php-cgi进程数。

20230119182959

PHP执行超时

如果访问网站时,直接提示“Nginx 502 Bad Gateway”错误,可能是PHP执行超时导致。

此时,您需要修改/usr/local/php/etc/php.ini配置文件,将文件中max_execution_time参数的值改为300。如下图所示,您需要将该参数的值从30修改为300

20230119182518

php-cgi进程异常中断

如果访问网站时,直接提示“Nginx 502 Bad Gateway”错误,可能是php-cgi进程异常中断导致。您需要执行如下步骤进行法排查:

  1. 远程登录
  2. 依次执行如下命令,查看php fastcgi的进程数和pm.max_children参数的值。netstat -anop | grep php-cgi | wc -l netstat -anpo | grep php-fpm | wc -l
  3. 执行如下命令,查看当前进程。ps aux | grep php-fpm 回显示例如下,查看fastcgi、php-fpm的进程数。如果进程数大于或等于5个,则表示需要增加进程数。在linux中访问网站提示“Nginx 502 bad gateway”错误如何处理?
  4. 修改/usr/local/php/etc/php-fpm.conf配置文件中的相关参数。
    • pm.max_children参数的值修改为5,表示支持5个进程。说明pm.max_children最多支持设置5个进程。按照每个进程20 MB内存,最多支持100 MB,即资源消耗时间为1分钟。如果pm.max_children增多,则php-cgi的进程增多,进程处理速度就会加快、排队的请求就会变少。但是设置pm.max_children也需要根据服务器的性能进行设定,一台服务器正常情况下,每一个php-cgi进程所耗费的内存在20 MB左右,您需要根据实际购买的服务器内存来决定pm.max_children的值。在linux中访问网站提示“Nginx 502 bad gateway”错误如何处理?
    • request_terminate_timeout参数的值修改为60,表示内存回收机制为1分钟(60秒)。说明request_terminate_timeout的值可以根据服务器的性能进行设定,常见设置为60秒。通常服务器性能越好,您可以设置的值越高。在linux中访问网站提示“Nginx 502 bad gateway”错误如何处理?
  5. 如果PHP进程的执行时间超过了Nginx的等待时间,则您需要适当增加Nginx的/etc/nginx.conf配置文件中fastcgi_connect_timeoutfastcgi_send_timeoutfastcgi_read_timeout参数的timeout时间,您需要修改的参数如下:在linux中访问网站提示“Nginx 502 bad gateway”错误如何处理?

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/10119

(0)
凯影的头像凯影
上一篇 2023年11月16日 下午2:24
下一篇 2023年11月17日 下午2:29

相关推荐

  • Linux SSH 登录失败多少次禁止该IP访问 防止暴力破解

    Linux 系统SSH 登录失败的内容会记录到/var/log/secure文件,通过查找关键字 Failed,可以定位到这些异常的IP地址,比如: 比如这里,明显这个IP地址在进行SSH 扫描,不断的更换端口和用户进行暴力测试。 在Linux里面有两个相关的文件: /etc/hosts.allow: 允许哪些IP访问主机 /etc/hosts.deny 禁…

    2023年3月1日
    1.8K00
  • 幻兽帕鲁服务器版本更新

    幻兽帕鲁服务器游戏怎么升级版本?自建幻兽帕鲁服务器进入Palworld游戏提示“您正尝试加入的比赛正在运行不兼容的游戏版本,请尝试升级游戏版本”什么原因?这是由于你的客户端和幻兽帕鲁服务器版本不匹配,如何解决?更新幻兽帕鲁服务器即可解决。 幻兽帕鲁进行一次更新,服务器也需要同步更新,才能继续游玩。 Linux服务器更新 1、使用如下命令,首先切换至root用…

    2024年2月4日
    4.5K00
  • Linux 命令神器:lsof

    lsof是系统管理/安全的尤伯工具。将这个工具称之为lsof真实名副其实,因为它是指“列出打开文件(lists openfiles)”。而有一点要切记,在Unix中一切(包括网络套接口)都是文件。 有趣的是,lsof也是有着最多开关的Linux/Unix命令之一。它有那么多的开关,它有许多选项支持使用-和+前缀。 正如你所见,lsof有着实在是令人惊讶的选项…

    2023年3月13日
    1.6K00
  • 如何自动备份文件到群晖NAS

    如何将电脑、服务器上的文件自动备份到群晖NAS? 方法有很多,今天给大家介绍两种最简单的方法: 方法1:Windows内置工具自动备份文件到群晖NAS 以下是使用Windows内置工具“备份和还原”,实现自动备份文件到群晖NAS的操作步骤。 步骤1. 打开控制面板,然后点击“备份和还原(Windows 7)”,然后点击右侧的“设置备份” 步骤2. 在设置备份…

    2024年5月30日
    1.5K00
  • Xcopy-windows命令行复制命令详解

    XCOPY是COPY的扩展,可以把指定的目录连文件和目录结构一并拷贝,但不能拷贝系统文件;使用时源盘符、源目标路径名、源文件名至少指定一个;选用/S时对源目录下及其子目录下的所有文件进行COPY。除非指定/E参数,否则/S不会拷贝空目录,若不指定/S参数,则XCOPY只拷贝源目录本身的文件,而不涉及其下的子目录;选用/V参数时,对拷贝的扇区都进行较验,但速度…

    2023年6月9日
    1.9K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信