Linux查看磁盘UUID的几种方式

查看/dev/disk/by-uuid目录
命令:

ls -l /dev/disk/by-uuid

可以查看系统全部磁盘挂载信息

[root@manager by-uuid]# ls -l /dev/disk/by-uuid
总用量 0
lrwxrwxrwx 1 root root 10 8月 29 21:32 3ee3afe8-4faf-4364-b142-488057e71480 -> ../../vda1

blkid命令
命令:

blkid -s UUID
[root@manager by-uuid]# blkid -s UUID
/dev/vda1: UUID="3ee3afe8-4faf-4364-b142-488057e71480"

也可以指定磁盘查看,命令:

blkid -s UUID /dev/vda1
[root@manager by-uuid]# blkid -s UUID /dev/vda1
/dev/vda1: UUID="3ee3afe8-4faf-4364-b142-488057e71480"

tune2fs和dumpe2fs配合grep
命令:

tune2fs -l /dev/vda1 |grep UUID
dumpe2fs /dev/vda1 |grep UUID
[root@manager by-uuid]# tune2fs -l /dev/vda1 |grep UUID
Filesystem UUID: 3ee3afe8-4faf-4364-b142-488057e71480


修改磁盘挂载ID,可以参考:https://help.aliyun.com/document_detail/199739.html
挂载磁盘千万不要使用

/dev/vdb1 /server ext4 defaults 0 0

这种方式,linux系统从启可能修改磁盘编号。严重情况可能导致系统无法启动。

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/9228

赞 (0)
郭靖的头像郭靖
上一篇 2023年7月28日 下午4:43
下一篇 2023年7月29日 下午5:15

相关推荐

  • Prometheus +grafana 监控PVE

    这边部署Prometheus +grafana,我就不详细描述了,之前的文章都有提到过。 pve后台在数据中心的菜单项里,多了一个度量服务器(Metric Server),中文显示“指标服务器”,翻译得怪怪的。 挡不住好奇,点进去看看,原来是添加远程数据统计服务器InfluxDB或者Graphite。 既然可以添加InfluxDB,那么在此基础上,整合Gra…

    2024年4月11日
    2.6K00
  • k8s-重启Pod方法

    kubectl 没有 restart pod 这个命令,主要是由于在 k8s 中pod 的管理属于rs 等控制器,并不需要手动维护,但有时更新了yaml文件后,期望破都能够”重启”重新加载yaml文件,比如修改了configmap 的配置文件后,希望重启pod 加载配置,此时就需要 “重启” Pod。而”重启”…

    2023年10月9日
    1.8K00
  • 手把手教你戴尔DELL 服务器 R410 带外管理iDRAC6 升级固件版本

    升级完R410的BIOS之后,第二个需求是更新远程管理的iDRAC版本。iDRAC需要服务器安装了远程管理卡才可以使用,然而一般现在网上买到的二手R410都是非常旧的iDRAC版本。(简单判断方法:管理页面是浅蓝色配色白底背景的是旧版本,新版本为深色背景) 和更新BIOS的问题相似,网上极少有关于服务器iDRAC更新的资料。且官方的文档说明也不全。经查阅整理…

    2024年1月22日
    2.7K00
  • 提高终端生产力神器 – tmux

    tmux github 一键安装 centos 系列可以直接用 yum debian 系列可以直接用 apt-get 编译安装 编译 libevent 编译 tmux 编译 tmux 还需要用到 ncurses 验证 tmux 是不是可用 如果出现报错:tmux: error while loading shared libraries: libevent_…

    2023年11月10日
    1.6K00
  • 服务器卡死,重启报错: INFO: task blocked for more than 120 seconds

    问题:服务器负载很高,但是CPU利用率不高。服务器经常夯住,网站打不开,SSH连接非常不稳定,输入命令夯住。 重启服务器报错: INFO: task blocked for more than 120 seconds 问题原因:  默认情况下, Linux会最多使用40%的可用内存作为文件系统缓存。当超过这个阈值后,文件系统会把将缓存中的内存全部写…

    2023年3月27日
    2.3K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信