Centos在dracut模式下如何修改系统配置文件

1、进入dracut原因

Centos系统进入dracut的原因有很多
比如:
系统重要文件丢失
系统配置文件配置错误等

2、恢复系统文件

2.1、dracut环境

在dracut上下文中是无法看到Centos系统文件的
dracut#

2.2、找到系统盘

Centos默认安装时,系统盘是一个lv设备

dracut# ls -l /dev/centos/root

如果安装时,手动修改了分区,那么可以根据实际情况找到系统设备
比如:

dracut# ls -l /dev/sda1

2.3、挂载系统盘

在dracut上下文中,创建临时目录

dracut# mkdir tmp1

dracut# mount /dev/centos/root tmp1

2.4、修改系统配置文件

dracut# cd tmp1
dracut# ls
bin boot dev etc home lib lib64 media mnt opt proc root run sbin srv sys tmp usr var

此时看到的就是Centos系统上下文了,可以进入/etc目录修改或者恢复配置文件

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/9027

(0)
郭靖的头像郭靖
上一篇 2023年6月9日 下午5:06
下一篇 2023年6月12日 下午4:54

相关推荐

  • CentOS7搭建LNMP环境教程

    一、安装nginx 创建 nginx.repo 文件 安装配置nginx 配置文件详解 启动并验证 二、安装MariaDB 安装mariadb 使用Mysql需先初始化密码 三、安装PHP更新yum源 执行下面的命令安装所需的包 启动php-fpm 创建测试文件 访问服务器,如果出现如下界面表示安装完成! 这样Lnmp环境就快速搭建完成了!!!

    2022年11月15日
    1.9K00
  • Linux JumpServer 堡垒机远程访问

    前言JumpServer 是广受欢迎的开源堡垒机,是符合 4A 规范的专业运维安全审计系统。JumpServer 帮助企业以更安全的方式管控和登录所有类型的资产,实现事前授权、事中监察、事后审计,满足等保合规要求。 下面介绍如何简单设置即可使本地jump server 结合cpolar 内网穿透实现远程访问jump server 管理界面. 安装环境后.使用…

    2023年12月20日
    1.5K00
  • Shell脚本——提取目录名和文件名

    在许多场景下,我们都需要对文件名称或者文件所在的目录进行操作,已达到我们业务目的。通常的操作是由路径中提取文件名,从路径中提取目录名,提取文件后缀等等一系列的操作。 一、${} 1.${var##*/} 2.${var##*.} 3.${var#*.} 4.${var%/*} 5.${var%%.*} 6.总结 其实 ${} 并不是专门为提取文件名或目录名的…

    2024年2月18日
    2.2K00
  • 在 Linux 上以 All-in-One 模式安装 KubeSphere

    步骤 1:准备 Linux 机器 若要以 All-in-One 模式进行安装,您仅需参考以下对机器硬件和操作系统的要求准备一台主机。 硬件推荐配置 操作系统 最低配置 Ubuntu 16.04, 18.04, 20.04, 22.04 2 核 CPU,4 GB 内存,40 GB 磁盘空间 Debian Bus…

    2023年4月18日
    1.4K00
  • 在Linux系统内启动某个服务时提示task: Cannot allocate memory该如何处理?

    问题现象 在ECS实例中启动某个服务进程时,系统提示task: Cannot allocate memory错误,如下图所示。 可能原因 可能是系统进程数超限导致。 Linux内核通过内核配置参数kernel.pid_max限制进程的数量,当运行的服务的总进程数超出kernel.pid_max的值时,再创建新进程时系统会报错task: Cannot allo…

    2023年11月14日
    1.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信