Oracle 日期时间查询

查询近一个月的数据:

ADD_MONTHS(sysdate,-1) <= CREATE_DATE
表示创建日期 CREATE_DATE 大于等于当前日期向前推1个月,即近一个月的数据。

Oracle根据当前时间查询前7天的数据:

Oracle数据库日期范围查询有两种方式:to_char方式和to_date方式,我们通过一个实例来介绍这一过程。我们假设要查询2022-05-02到2022-05-30之间的数据,实现方式如下:

to_date方式

SELECT
    *
FROM
    tablename
WHERE
    TIME >= TO_DATE ('2022-05-02', 'yyyy-mm-dd')
AND TIME <= TO_DATE ('2022-05-30', 'yyyy-mm-dd')
运行的结果是:可以显示05-02的数据,但是不能显示05-30的数据。

to_char方式

SELECT
    *
FROM
    tablename
WHERE
    TO_CHAR (TIME, 'yyyy-mm-dd') >= '2022-05-02'
AND TO_CHAR (TIME, 'yyyy-mm-dd') <= '2022-05-30'

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/7757

赞 (0)
郭靖的头像郭靖
上一篇 2023年3月24日 下午4:40
下一篇 2023年3月25日 下午3:17

相关推荐

  • MySQL 如何避免克隆失败后再次初始化

    在我之前关于 CLONE INSTANCE 命令的博客文章《MySQL 克隆插件不是你的备份》中,我提到使用选项 DATA DIRECTORY 有助于避免在克隆操作失败时需要从头开始重新初始化副本和克隆相关设置的情况。 MySQL 克隆插件简化了新副本的配置,但不会简化失败后的服务器恢复,除非您准备从头开始重新安装 M…

    2023年10月23日
    2.0K00
  • 使用数据库工具储存文件报错1558解决方法

    现象:在用navicat连接时发生了一个错误:1558 column count of mysql.proc is wrong.Expected20,found 16.created with mysql 50091,now running 50528.please use mysql_upgrade to fix this error。 分析过程:这个是由…

    2022年12月7日
    2.1K00
  • MySQL数据库断电修复(Database page corruption on disk or a failed)

    一、报错信息 启动日志如下: 看日志的大体的意思是数据页的损坏。 二、解决方案 2.1 修改配置  /etc/my.cnf 配置文件修改innodb 启动参数修改 如果innodb_force_recovery = 1不生效,则可尝试2-6几个数字。 然后重启mysql,重启成功。然后使用mysqldump或 pma 导出数据,执行修复操作等。修复完成后,把…

    2023年12月29日
    2.4K00
  • KeyDB: 一款比 Redis 性能更强的分布式数据库

    eyDB 是一个开源的,高性能的,多线程的内存键值存储。它是流行的 Redis 数据库的分支版本,完全兼容 Redis 命令和数据类型。KeyDB 提供了很多的高级功能,如 Lua 脚本,LRU 淘汰和命令的并行执行。它是为企业环境构建的,提供高可用性和集群支持。KeyDB 也针对速度进行了优化,基准测试表明它是可用的键值存储之一。总的来说,KeyDB 是内…

    2023年6月28日
    1.9K00
  • MySQL常见错误代码

    MySQL常见错误代码及代码说明 1005:创建表失败 1006:创建数据库失败 1007:数据库已存在,创建数据库失败<=================可以忽略 1008:数据库不存在,删除数据库失败<=================可以忽略 1009:不能删除数据库文件导致删除数据库失败 1010:不能删除数据目录导致删除数据库失败 10…

    2023年3月28日
    1.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信