TrueNAS创建NFS共享

  • truenas安装后进行登录,默认账号:root 密码为:安装时进行设置的这里我们添加一个账户,用户NFS或SMB共享
TrueNAS创建NFS共享
  • 在存储池中创建数据集
TrueNAS创建NFS共享
  • 设置好共享数据集的权限
TrueNAS创建NFS共享
  • 设置好共享路径目录
NAS权限设置
NAS权限设置
TrueNAS创建NFS共享
NFS目录设置
NFS目录设置
  • 高级选项设置
TrueNAS创建NFS共享

NFS高级选项: 同一个NFS共享中 “Maproot” 和 “Mapall” 二者只能使用一个。即便你两项都进行了设置,系统也会默认用 “Mapall” 的设置覆盖 “Maproot” 设置。如果只希望限制 root 用户权限,则设置 “Maproot” 选项。如果希望限制所有用户的权限,则设置 “Mapall” 选项。 卷和数据集会被视为独立的文件系统,NFS无法超越文件系统边界。 每个共享、文件系统或文件夹的网络或主机名必须是唯一的。 每个共享的文件系统只能设置一次“All directories”。 Path:共享路径,选择要通过NFS共享的卷/数据集;点击“Add extra path”连接,可以同时添加多个共享路径; Comment:共享名称,如果留空,则默认以共享路径作为共享名称; All directories:如果选中此项,则允许用户挂载共享路径下的所有子目录; Read only:只读模式,选中此项,则禁用共享目录的写权限; Authorized networks:授权的网络,格式为 1.2.3.0/24,用空格分隔多个网段; Authorized IP addresses or hosts:授权的IP或主机,用空格分隔多个网段; Quiet:静默模式,用于阻止闹人的错误提示; Maproot User:root用户将被限制为只具有所选用户的权限; Maproot Group:root用户将被限制为只具有所选用户组的权限; Mapall User:所有挂载NFS共享的客户端都将以所选用户权限访问; Mapall Group:所有挂载NFS共享的客户端都将以所选用户组权限访问; Security:选择安全机制

  • 启用NFSv4
TrueNAS创建NFS共享
  • 用exsi7.0挂载刚刚创建的NFS共享目录medai
TrueNAS创建NFS共享
TrueNAS创建NFS共享
TrueNAS创建NFS共享

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/7348

赞 (0)
郭靖的头像郭靖
上一篇 2023年2月22日 下午3:38
下一篇 2023年2月23日 下午3:10

相关推荐

  • Windows 2008实例更新补丁出现“8000FFFFwindows update 遇到未知的错误”报错如何处理?

    问题描述 Windows 2008实例更新补丁时出现“8000FFFFwindows update 遇到未知的错误”报错,如下图所示。 问题原因 由于系统的C盘没有设置Users权限,导致系统无法正常安装更新的补丁。 解决方案 方案一 方案二 如果方案一无法解决问题,请参考以下操作步骤。

    2023年11月20日
    1.3K00
  • Windows配置磁盘监控

    通过pushgateway的方式,主动推送监控数据给prometheus。 由于windows平台的诸多限制,导致推送比较艰难。有两种方法完成监控。 1.通过python等语言,做推送脚本。 2.曲线救国就是把监控数据scp发给Linux机器。再通过linux做二次加工推给pushgateway。 window server上配置环境 1.首先判断服务器磁盘…

    2022年11月25日
    1.8K00
  • Windows实例内部自定义域名解析与本地网络域名解析不一致导致无法访问网站如何处理?

    问题描述 在Windows实例内部通过浏览器无法访问某网站,但在其他设备上可以正常访问,排查发现Windows实例内部自定义域名解析与本地网络域名解析不一致,具体说明如下: 问题原因 Windows实例内部和本地域名解析的IP地址不一致的可能原因如下: 解决方案 说明 本文操作以Windows Server 2019 数据中心版 64位中文版操作系统为例,其…

    2023年11月20日
    1.5K00
  • Word找回没有保存的文件方法

      1、“不保存”找回文件。   当我们关闭文档时,会提示,是否保存,如果点错了,直接点击“不保存”,咋办?   再次启动 Word,进入「打开」,选择右侧的「恢复未保存的文档」,在这里,我们可以看到许多文件,这些文件全部都是点击了“不保存”,没有保存下来的文件,找到我们需要的文件,然后“打开”即可。   2、死机、断电等导致文件丢失。   如果你正在使用 …

    2024年6月17日
    1.9K00
  • Windows server 2008 R2 服务报错14001解决方案

    错误 14001:因为应用程序的并行配置不正确 有关详细信息 请参阅应用程序事件日志 或使用命令行 sxstrace.exe 工具 今日通过服务管理器重新启动mysql服务时发现报错14001,解决方案如下: 打开左下角服务管理器,点击功能,然后添加功能,添加 Framework 3.51全部功能,这样就可以去服务管理器中启动服务了!!!

    2022年11月22日
    2.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信