IIS发布网站时报403错误的所有原因及解决方案

在使用IIS的时候,如果遇到403相关的错误,我们往往束手无策,不知道是什么权限的原因。现总结如下,供以后参考。

1、403.1 – 执行访问被禁止

没有足够的执行权限,例如你访问的index.php文件,但是该文件并没有执行权限,那么浏览器在访问时就会出现该错误,然后你就需要去修改目录的权限了


2、403.2 – 读访问被禁止
验证是否已将IIS设置为允许对目录进行读访问。


3、403.3 – 写访问被禁止
验证IIS权限和NTFS权限是否 已设置以便向该目录授予写访问权。


4、403.4 – 要求SSL
  禁用要求安全通道选项,或使用HTTPS代替HTTP来访问该页面。如果没有安装证书 的Web站点出现此错误。


5、403.5 – 要求SSL 128
  禁用要求128位加密选项,或使用支持128位加密的浏览器以查看该页面。如果没有安装证书的Web站点出现此错误


6、403.6 – IP地址被拒绝
 您已把您的服务器配置为拒绝访问您目前的IP地址。


7、403.7 – 要求客户端证书
 您已把您的服务器配置为要求客户端身份验证证书,但您未安装有效的客户端证书。


8、403.8 – 站点访问被拒绝
  您已为您用来访问服务器的域设置了域名限制。


9、403.9 – 用户数过多
 与该服务器连接的用户数量超过了您设置的连接限制。


10、403.10 – 配置无效


11、403.11 – 密码更改


12、403.12 – 拒绝访问映射表
 您要访问的页面要求提供客户端证书,但映射到您的客户端证书的用户ID已被拒绝访问该文件。


13、403.13 – 客户端证书被吊销


14、403.14 – 拒绝目录列表

您要访问的页面被拒绝了,问题所在就是iis没有办法读取这个页面的源文件,那么就需要去看iis的默认文档中,是否支持该文件,比如你的文件时php文件,那就就可以看默认文档是否存在index.php即可

15、403.15 – 超出客户端访问许可

16、403.16 – 客户端证书不受信任或无效

17、403.17 – 客户端证书已过期或尚未生效

18、403.18 – 在当前的应用程序池中不能执行所请求的URL(IIS 6.0专有)

19、403.19 – 不能为这个应用程序池中的客户端执行CGI(IIS 6.0专有)

20、403.20 – Passport登录失败(IIS 6.0专有)

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/5043

赞 (0)
郭靖的头像郭靖
上一篇 2022年6月20日 下午4:48
下一篇 2022年6月21日 下午3:49

相关推荐

  • 如何通过宝塔面板配置ssl证书

    至于宝塔的安装以及如何安装环境搭建网站,大家可以看我们的另一篇文章: Centos7.6下宝塔安装及资产管理系统部署 基于宝塔面板配置网站ssl证书支持https访问其实很简单,不需要你懂什么技术知识。接下来你跟着我的步骤,就能成功配置网站ssl。 宝塔面板后台设置成功如图所示: 第一步:点击设置 第二步:点击右侧的SSL,选择宝塔SSL,点击申请证书 第三…

    2022年6月14日
    3.1K00
  • 如何修改WordPress底部版权信息?

    wordpress安装之后,有不少默认设置需要我们修改,wordpress网站底部版权信息就是其中之一,在网站最下面页脚那个位置,会有一段英文声明,如下所示。 © 2019 My WordPress Proudly powered by WordPress 如果你使用的不是wordpress默认主题,底部版权信息会根据wordpress主题的不同,被开发者写…

    2024年1月29日
    3.0K00
  • 已解决:Strict Standards: Non-static method cls_image::gd_version() should not be called statically in…..

    iis网站更换php版本后,遇到问题 原因:PHP升级到5.4X以后的兼容性语法问题 解决: 将php版本换回5.4之前的版本就可以解决

    2023年3月17日
    1.7K00
  • kibana报错:Unable to revive connection: http://localhost:9200/解决办法

    kibana报错:Unable to revive connection: http://localhost:9200/ 第一种情况(新手):先把elasticsearch.bat打开,再打开kibana.bat,原因主要是不打开elasticsearch自然生成不了地址,kibana自然也就找不到地址。如果不行请采用第二种或第三种。 第二种方法:通过doc…

    2023年8月23日
    2.3K00
  • 解决discuz论坛搬家:“Table ‘common_syscache’ is read only”问题

    网站搬家采用直接打包mysql数据库和网页文件的形式进行迁移,上传好mysql data目录里面的网站数据库至mysql存放数据库的目录里面,解压就行,我的存放数据库的路径是 /usr/local/mysql/var,上传好网站数据,解压,配置好数据库链接参数就行,网站就能正常连接上了,我本以为这已经是顺利迁移完成了,但后来操作的时候,发现只能读取数据库的内…

    2023年2月15日
    1.5K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信