MySQL的备份与还原

关于删库跑路的事故现在已经屡见不鲜了,数据备份的必要性是企业数据管理极其重要的一项工作。关于数据备份、恢复也有很多场景及方法,本系列也会将主要的方法进行演示。

方式一:通过cmd命令备份

备份

数据表结构+数据 db1为要备份的数据库名,db2.sql为输出备份文件名称备份后输出一个sql文件,存在指定的/root/mysql_bak/目录下

备份数据库的表结构和数据

mysqldump -u root -p db1 > /root/mysql_bak/db2.sql

备份数据库的指定表的表结构和数据

mysqldump -u root -p db1 table1 > /root/mysql_bak/table1_bak.sql

只备份数据库的数据表结构

mysqldump -u root -d db1 > /root/mysql_bak/db3.sql -p

还原

1.先创建一个新的数据库

create database dbnew;

2.将备份的数据库文件导入到dbnew数据库中

use dbnew;
source /root/mysql_bak/db2.sql;

方法二:使用dbeaver工具备份与还原

备份

选中所需要的备份的数据库右键—》选择工具–》选择导出数据库

MySQL的备份与还原

弹出导出数据库的界面,选择自己所需要的表

MySQL的备份与还原

指定导出的位置,导出文件的名称,以及文件的编码格式,若是只想导出表结构不需要数据,则需将仅结构勾选上

--set-gtid-purged=OFF

MySQL的备份与还原

等待备份完成

MySQL的备份与还原

还原

选择需要还原的数据库右键–》选择工具–》选择导入数据库

MySQL的备份与还原

选择备份的文件,输入还原的格式编码

--default-character-set=utf8

等待还原完成

MySQL的备份与还原

此时新的数据库已经备份完成了。

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/4432

赞 (0)
安屠生的头像安屠生
上一篇 2022年6月10日 下午5:14
下一篇 2022年6月11日 上午10:20

相关推荐

  • MySQL数据库断电修复(Database page corruption on disk or a failed)

    一、报错信息 启动日志如下: 看日志的大体的意思是数据页的损坏。 二、解决方案 2.1 修改配置  /etc/my.cnf 配置文件修改innodb 启动参数修改 如果innodb_force_recovery = 1不生效,则可尝试2-6几个数字。 然后重启mysql,重启成功。然后使用mysqldump或 pma 导出数据,执行修复操作等。修复完成后,把…

    2023年12月29日
    2.4K00
  • Oracle 日期时间查询

    查询近一个月的数据: 表示创建日期 CREATE_DATE 大于等于当前日期向前推1个月,即近一个月的数据。 Oracle根据当前时间查询前7天的数据: Oracle数据库日期范围查询有两种方式:to_char方式和to_date方式,我们通过一个实例来介绍这一过程。我们假设要查询2022-05-02到2022-05-30之间的数据,实现方式如下: to_d…

    2023年3月25日
    1.8K00
  • Linux在线yum方式安装mysql5.7(适用于mysql8.0)

    Linux下软件常见部署方式有三种:yum安装、rpm安装以及编译安装。由于离线、编译需要先下载多个文件再安装,步骤较多,所以整理了一下在线安装mysql的方法,文中系统为CentOS7.9版本。 1.配置好yum源,包括epel源 使用官方yum仓库,官方下载链接 2. 生成yum源缓存并查看mysql版本 从enable状态来看,默认启用的是最新8.0版…

    2023年1月1日
    1.9K00
  • Navicat161 数据库文件修复

    错误分析 此错误一般为表损坏,修复即可。可能造成原因为服务器突然断电,而有程序还在往表里写数据或者表的数据很大或者数据搬迁的时候编码格式有误,避免浪费时间去修表,可采用Navicat去快速修复表!!! 登录Navicat数据库,找到报错的数据表,右键维护->修复表->拓展或者快速

    2022年11月17日
    2.1K00
  • MySQL配置文件参数详解

    设定MySQL事务是否自动提交,1表示立即提交,0表示需要显式提交。作用范围为全局或会话,可用于配置文件中(但在5.5.8之前的版本中不可用于配置文件),属于动态变量。 设定MySQL服务器是否为存储例程的创建赋予其创建存储例程上的EXECUTE和ALTER ROUTINE权限,默认为1(赋予此两个权限给其创建者)。作用范围为全局。 当MySQL的主线程在短…

    2022年8月16日
    1.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信