Linux系统部署BBR服务器加速软件

一、BBR加速软件介绍
  BBR简介:
  BBR是谷歌的黑科技,也可以理解为用来加速网络的软件,如果服务器在海外,会发现丢包率很高,线路还会时断时续。所以,不用点黑科技,肯定是没办法使用。而BBR加速能充分利用网络带宽

BBR的作用就是尽量跑满带宽,并且尽量不要有排队的情况。BBR可以起到单边加速TCP连接的效果。通俗来讲就是最大化利用网络上瓶颈线路的带宽。说白了,就是在极限的情况下,将速度发挥到极致,也就是把带宽压榨到极致

  BBR解决的问题:
  在有一定丢包率的网络链路上充分利用带宽。非常适合高延迟,高带宽的网络线路。降低网络线路上的buffer占用率,从而降低延迟。非常适合慢速接入网络的用户。说白了就是用大宽带满速解决丢包高延迟问题,非常适合远地区的服务器。

  国内服务器是否适合安装BBR?
  BBR是拥塞控制算法,拥塞也就是数据包丢包,传统拥塞控制算法,当出现拥塞时,会使发送数据窗口大幅减少,导致数据传送效率急剧降低。国内云网络一般丢包率很低(但不代表不丢包),开不开BBR,理论上影响不大,BBR对国际线路提升比较明显,国际线路丢包特别严重。

BBR目前已经集成在Linux内核中,也就是说大家几乎都已经用上了BBR加速。原版BBR,让大家的速度提升一个档次,但没有达到极致,于是魔改BBR和BBR Plus出现了,他们都是基于原版bbr修改而来,只是修改了一些参数,就让这些BBR带有了更强的抢占带宽的能力

  BBR工作原理:
  拥塞现象是指到达通信子网中某一部分的分组数量过多,使得该部分网络来不及处理,以致引起这部分乃至整个网络性能下降的现象,严重时甚至会导致网络通信业务陷入停顿,即出现死锁现象。这种现象跟公路网中经常所见的交通拥挤一样,当节假日公路网中车辆大量增加时,各种走向的车流相互干扰,使每辆车到达目的地的时间都相对增加(即延迟增加),甚至有时在某段公路上车辆因堵塞而无法开动,即发生局部死锁。
  拥塞控制就是针对此问题的控制技术/解决方案,但也不能说是解决,控制技术只能起到尽量避免/缓解拥塞的作。
  TCP-BBR技术用了一种溢水原理的思想,来预判丢包率,调配发包速率。
  假设你有一支较细的U形管,下面还有一堆不可溶的填塞物,你从一边开始大量灌水,如果另一边出水正常,你就可以继续加大灌水量,达到最大带宽。
  如果另一边发现水时断时有,就证明下面出现了随机拥堵,这时,你就要减小灌水量,等待水位落下,这时如果采用传统继续灌水时,也就会造成水溢出(丢包现象的产生),所以这是真正的按需发包。

二、BBR软件的部署
  在安装BBR软件的服务器中创建一个大文件,用于下载测试:

dd if=/dev/zero of=/root/test count=2 bs=512M

未安装BBR之前下载速度测试:

Linux系统部署BBR服务器加速软件

通过一键脚本安装并启动BBR:

wget -N --no-check-certificate "http://cdn.1doc.top/sh/tcp.sh" && chmod +x tcp.sh && ./tcp.sh

安装后会改变原有linux内核,可能会影响某些功能。使用BBRCentOS 7服务器的内核版本至少是4.9.0

系统原内核版本:
uname -r
5.15.0-75-generic

uname -r
5.15.0-75-generic

国内服务器不需要安装BBR,不支持的linux发行版不要安装,生产环境不建议后安装

安装过程如下:
  运行命令后,BBR管理脚本会自动打开,打开脚本后,输入2并回车,会下载一个BBRplus的包,等待出现提示是否重启

Linux系统部署BBR服务器加速软件
Linux系统部署BBR服务器加速软件
Linux系统部署BBR服务器加速软件

重启服务器后,输入./tcp.sh打开bbr管理脚本

./tcp.sh

输入7并回车,启动BBRplus加速:

Linux系统部署BBR服务器加速软件

再次打开BBR管理脚本,输入10回车,再输入y回车。等待重启,重启后就可以使用了:

Linux系统部署BBR服务器加速软件

接下来验证BBR加速是否安装成功:

# sysctl net.ipv4.tcp_available_congestion_control
net.ipv4.tcp_available_congestion_control = reno cubic bbr

# sysctl -n net.ipv4.tcp_congestion_control
bbr

# lsmod | grep bbr
tcp_bbr                20480  1

或者使用如下脚本安装方式(自动开启BBR):

wget --no-check-certificate https://github.com/teddysun/across/raw/master/bbr.sh && chmod +x bbr.sh && ./bbr.sh

看到输出以上信息就说明BBR加速功能生效了。
  对安装BBR之后下载速度测试:

Linux系统部署BBR服务器加速软件

其他BBR版本与以上方一样,可以尝试使用其他BBR版本,选择对自己的服务器效果最好的版本即可

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/10312

(0)
凯影的头像凯影
上一篇 2023年12月1日 下午2:17
下一篇 2023年12月5日 下午2:20

相关推荐

  • /etc/security/limits.conf配置文件详解

    /etc/security/limits.conf 是一个用于配置用户或用户组资源限制的配置文件。这个文件通常用于设置系统资源的软限制和硬限制,以及一些特殊权限。 一. limits.conf常见配置项详解 下面是一些 /etc/security/limits.conf 文件中可能包含的常见配置项: 描述 第一列表示用户和组(@开头),这里的 * 代表所有用…

    2024年5月14日
    1.7K00
  • Docker Dockerfile 使用方法

    Dockerfile 介绍 当使用Docker构建容器化应用程序时,Dockerfile是一个用于定义容器镜像的文本文件。它包含了一系列指令,告诉Docker如何从基础镜像(通常是官方或自定义的操作系统镜像)构建出最终的镜像,以及如何配置容器中的环境、文件和应用程序。 Dockerfile 的编写是构建容器的基础,它允许您定义容器的构建步骤、环境和配置。通过…

    2024年2月2日
    1.7K00
  • Linux中监测磁盘IO性能

    Linux 存储系统 I/O 栈由文件系统层(file system layer)、通用块层( general block layer)和设备层(device layer)构成。 其中,通用块层是 Linux 磁盘 I/O 的核心。向上,它为访问文件系统和应用程序的块设备提供了标准接口;向下,它将各种异构磁盘设备抽象为一个统一的块设备,并响应文件系统和应用程…

    2022年12月1日
    1.6K00
  • CentOS 修改 SSH无操作自动断开时长及连接超时

    CentOS 修改 SSH无操作自动断开时长 当 SSH 连接到 CentOS 服务器时, 如果一段时间不操作, SSH 会自动断开。 这时, 可修改配置增加连接时长。 一、修改配置 在配置中找到 修改为 ClientAliveInterval 指定了服务器端向客户端发送消息的间隔,默认 0 不发送消息。ClientAliveInterval 30…

    2023年2月20日
    3.0K00
  • Minio nginx配置https和http问题解决,疑难症全网首发

    以下问题基本上是因为NGINX代理出现 一、API直接返回单独的错误: io.minio.errors.ErrorResponseException: Access denied 二、API直接返回的错误:The request signature we calculated does not match the si 三、预览文件或者图片返回错误 以上三个…

    2023年10月18日
    4.4K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信