CentOS 修改 SSH无操作自动断开时长及连接超时

CentOS 修改 SSH无操作自动断开时长

当 SSH 连接到 CentOS 服务器时, 如果一段时间不操作, SSH 会自动断开。 这时, 可修改配置增加连接时长。

一、修改配置

vim /etc/ssh/sshd_config

在配置中找到

#ClientAliveInterval 0
#ClientAliveCountMax 3

修改为

ClientAliveInterval 30
ClientAliveCountMax 3

ClientAliveInterval 指定了服务器端向客户端发送消息的间隔,默认 0 不发送消息。
ClientAliveInterval 30 服务器端每 30 秒发送一次消息。
ClientAliveCountMax 服务器端发送消息后客户端没有响应的次数达到一定值,就自动断开。

二、重启 sshd

重启 sshd 使配置生效。

service sshd restart

linux设置ssh连接超时时间

第一步: 修改/root/.bash_profile文件,新增export TMOUT=1000000(以秒为单位)

第二步: 让这个修改过后的文件生效 source .bash_profile

第三步: 备份一份原来的ssh配置文件,免得改错没机会恢复了

第四步: 修改ssh的配置文件,新增ClientAliveInterval=60

每一分钟,sshd都和ssh client打个招呼,检测它是否存在,不存时即断开连接。
注意:设置完成后,要退出ssh远程连接,再次登录后才可以生效。因为要再读取一次./bash_profile。

以下是一个脚本,复制黏贴即可,一定要在root用户下执行,不然会权限不足

echo export TMOUT=1000000 >> /root/.bash_profile
cat /root/.bash_profile
source .bash_profile
cp /etc/ssh/sshd_config /etc/ssh/sshd_config_bak
echo ClientAliveInterval=60 >> /etc/ssh/sshd_config
service sshd restart
cat /etc/ssh/sshd_config
exit

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/7304

赞 (0)
郭靖的头像郭靖
上一篇 2023年2月20日 下午12:05
下一篇 2023年2月21日 下午5:03

相关推荐

  • 在linux中访问网站提示“Nginx 502 bad gateway”错误如何处理?

    问题原因 “Nginx 502 Bad Gateway”错误表示访问请求的php-cgi进程已经开始执行,但是由于读取资源失败等原因没有执行完毕,导致php-cgi进程终止。 常见的问题原因如下: 解决方案 您可以参考如下操作进行逐一排查。 说明 本文中/usr/local/php/etc/php-fpm.conf、/usr/local/php/etc/ph…

    2023年11月16日
    1.5K00
  • K8S集群搭建高可用prometheus+grafana

    使用k3s来搭建测试环境。 为什么使用k3s K3s 是一个轻量级的、完全兼容的 Kubernetes 发行版本。非常适合测试。 K3s将所有 Kubernetes 控制平面组件都封装在单个二进制文件和进程中,文件大小<100M,占用资源更小,且包含了kubernetes运行所需要的部分外部依赖和本地存储提供程序。 K3s提供了离线安装包,安装起来非常…

    2022年11月22日
    1.9K00
  • 在 Linux 上以 All-in-One 模式安装 KubeSphere

    步骤 1:准备 Linux 机器 若要以 All-in-One 模式进行安装,您仅需参考以下对机器硬件和操作系统的要求准备一台主机。 硬件推荐配置 操作系统 最低配置 Ubuntu 16.04, 18.04, 20.04, 22.04 2 核 CPU,4 GB 内存,40 GB 磁盘空间 Debian Bus…

    2023年4月18日
    1.4K00
  • vnstat 统计服务器网卡流量

    vnStat 是一款开源的网络流量统计工具,可以方便的查看当天,当月流量统计。官网地址: 安装 在 Debian/Ubuntu 下非常简单 假设网卡名为 eth0,该配置在 /etc/vnstat.conf 中,安装结束后初始化数据库 添加为开机启动 使用 直接输入 vnstat 图形化输出可以使用 vnst…

    2023年9月25日
    1.5K00
  • 多台服务器如何设置SSH免密登录

    本次测试需要服务器己安装好 ssh-keygen和ssh-copy-id。安装方式如下: 安装ssh-keygen和ssh-copy-id 1、在客户端机器上生成密钥,这里连续三个回车默认即可。 3、进入到/root/.ssh/目录下,查看是否生成密钥成功,这里一共生成三个文件,本次主要用到的是id_rsa.pub:私钥(本次实验用到的) 4、通过命令复制私…

    2022年6月16日
    2.1K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信