Nginx 代理多个服务器(多个server方式)

1.介绍

1.1 背景介绍

  • 如果每台linux服务器只运行了一个小网站,那么人气低,流量小的草根站长需要承担高额的服务器租赁费,也造成了硬件资源浪费。
  • 虚拟主机就是将一台服务器分割成多个“虚拟服务器”,每个站点使用各自的硬盘空间,由于省资源,省钱,众多网站都使用虚拟主机来部署网站。
  • 虚拟主机的概念就是在web服务里的一个独立的网站站点,这个站点对应独立的域名(IP),具有独立的程序和资源目录,可以独立的对外提供服务。
  • 这个独立的站点配置是在nginx.conf中使用server{}代码块标签来表示一个虚拟主机。
  • Nginx支持多个server{}标签,即支持多个虚拟主机站点。
  • 虚拟主机定义了网站的端口,域名,网页内容存放路径

1.2 虚拟主机类型

  • 基于域名的虚拟主机
  • 通过不同的域名区分不同的虚拟主机,是企业应用最广的虚拟主机。
  • 基于端口的虚拟主机
  • 通过不同的端口来区分不同的虚拟主机,一般用作企业内部网站,不对外直接提供服务的后台,例如www.pythonav.cn:9000
  • 基于IP的虚拟主机
  • 通过不同的IP区分不同的虚拟主机,此类比较少见,一般业务需要多IP的常见都会在负载均衡中绑定IP1.3 多虚拟主机 使用基于域名
  • nginx可以自动识别用户请求的域名,根据不同的域名请求服务器传输不同的内容,只需要保证服务器上有一个可用的ip地址,配置好dns解析服务。
  • /etc/hosts是linux系统中本地dns解析的配置文件,同样可以达到域名访问效果

2.多虚拟主机案例(基于IP)

2.1 环境准备

基于多域名的虚拟主机实现,其实就是读个server标签   

环境准备,
1个linux服务器, ip地址:10.0.0.129

安装好nginx软件

在windows中写入2个hosts假的域名
找到如下文件,编辑写入域名对应关系(C:\windows\System32\drivers\etc\hosts)

10.0.0.129 www.dbjwb.com
10.0.0.129 www.dbjapi.com

2.2 修给nginx.conf的配置,

  • 实现多虚拟主机,多个server{}标签是同级的关系

2.2.1 server

# 第一个主机,域名部分替换为你自己的域名,此处是随意写的
server {
        # 监听的端口号 
        listen       80;
        server_name  www.yourdomain1.com;
        location / {
            # root参数定义网页的根目录,
            root   /opt/api/;
            # 指定首页文件的名字,两个都是,可以删掉一个
            index  index.html;
        }
} 
# 第二个主机
server {
        listen  80;
        server_name  www.yourdomain2.com;
        location / {
            root   /opt/wb/;
            index  index.html;
        }
}   

2.2.2 完整配置

# 进程数
worker_processes  1;
events {
    worker_connections  1024;
}
# 核心代码
http {
    include       mime.types;
    default_type  application/octet-stream;
    # 定义nginx访问日志的格式 
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';
    # 访问日志的功能
    access_log  logs/access.log  main;
    # 推图片等静态文件压缩,提升传输效率
    gizp  on;
    #server被称为虚拟主机,可以有多个
    # 第一个主机
    server {
        # 监听的端口号 
        listen       80;
        server_name  www.yourdomain1.com;
        location / {
            # root参数定义网页的根目录,
            root   /opt/api/;
            # 指定首页文件的名字,两个都是,可以删掉一个
            index  index.html;
        }
} 
# 第二个主机
server {
        listen  80;
        server_name  www.yourdomain2.com;
        location / {
            root   /opt/wb/;
            index  index.html;
        }
}   
}

2.2.3 创建文件夹/index.html

新建文件夹  
mkdir -p /opt/{api,wb}

各自新建一个index.html,写入内容,随便找一个html
vim index.html

2.3 重启nginx

nginx -s reload

2.4 访问对应的域名,即可看见内容

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/5124

赞 (4)
安屠生的头像安屠生
上一篇 2022年6月22日 下午3:12
下一篇 2022年6月24日 下午3:42

相关推荐

  • 清华源连接失败原因与解决 CondaHTTPError SSLError

    Conda 清华源连接失败原因与解决 问题描述 在我设置好国内源之后,用conda创建虚拟环境,下载python版本时出现以下错误。 我的~/.condarc内容(即conda channels设置)如下 解决方案 在我查阅了多篇博客,尝试了多种方案之后,终于找到两种解决方案: 两种方法选一种即可 原因分析 https协议比http协议多了SSL,TLS等验…

    2023年3月23日
    3.2K00
  • Centos7.6安装MySQL(超详细)

    1、查看是否已经安装Mysql rpm -qa | grep mysql 我已经安装过了 如果你查看出来有东西,可以使用下面命令将其删除 rpm -e 文件名 如果提示warning: waiting for transaction lock on /var/lib/rpm/.rpm.lock,则需要执行 2、下载官方Mysql包 wget -i -c ht…

    2022年6月9日
    2.1K00
  • Windows系统批量绑定删除多IP以及Linux系统批量绑定IP

    一、Windows系统 1.1个IP绑定 在网络连接中,选择更改适配器设置,选择本地连接,右键属性,选择Internet 协议版本4双击打开。 在其中选择”使用下面的IP地址”,填写相关信息,确认即可 2.2个IP的绑定 点击IPV4属性中的高级,选择IP地址的添加,添加IP地址及子网掩码即可 3.多个IP的绑定 使用命令,打开cmd…

    2022年6月9日
    2.7K00
  • Prometheus +grafana 监控PVE

    这边部署Prometheus +grafana,我就不详细描述了,之前的文章都有提到过。 pve后台在数据中心的菜单项里,多了一个度量服务器(Metric Server),中文显示“指标服务器”,翻译得怪怪的。 挡不住好奇,点进去看看,原来是添加远程数据统计服务器InfluxDB或者Graphite。 既然可以添加InfluxDB,那么在此基础上,整合Gra…

    2024年4月11日
    2.5K00
  • SonarQube支持Gitlab授权登录

    背景 部署好SonarQube之后,由于我们内部使用的是自建的Gitlab仓库,即每个开发同学都有Gitlab账号,SonarQube我们就可以使用上Gitlab登录,这样就不需要再维护一套用户体系了。 环境: SonarQube8.9.2 社区版 GitLab Enterprise Edition 11.10.4-ee 具体配置: Gitlab 配置: 在…

    2023年1月20日
    2.1K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信