Nginx 代理多个服务器(多个server方式)

1.介绍

1.1 背景介绍

  • 如果每台linux服务器只运行了一个小网站,那么人气低,流量小的草根站长需要承担高额的服务器租赁费,也造成了硬件资源浪费。
  • 虚拟主机就是将一台服务器分割成多个“虚拟服务器”,每个站点使用各自的硬盘空间,由于省资源,省钱,众多网站都使用虚拟主机来部署网站。
  • 虚拟主机的概念就是在web服务里的一个独立的网站站点,这个站点对应独立的域名(IP),具有独立的程序和资源目录,可以独立的对外提供服务。
  • 这个独立的站点配置是在nginx.conf中使用server{}代码块标签来表示一个虚拟主机。
  • Nginx支持多个server{}标签,即支持多个虚拟主机站点。
  • 虚拟主机定义了网站的端口,域名,网页内容存放路径

1.2 虚拟主机类型

  • 基于域名的虚拟主机
  • 通过不同的域名区分不同的虚拟主机,是企业应用最广的虚拟主机。
  • 基于端口的虚拟主机
  • 通过不同的端口来区分不同的虚拟主机,一般用作企业内部网站,不对外直接提供服务的后台,例如www.pythonav.cn:9000
  • 基于IP的虚拟主机
  • 通过不同的IP区分不同的虚拟主机,此类比较少见,一般业务需要多IP的常见都会在负载均衡中绑定IP1.3 多虚拟主机 使用基于域名
  • nginx可以自动识别用户请求的域名,根据不同的域名请求服务器传输不同的内容,只需要保证服务器上有一个可用的ip地址,配置好dns解析服务。
  • /etc/hosts是linux系统中本地dns解析的配置文件,同样可以达到域名访问效果

2.多虚拟主机案例(基于IP)

2.1 环境准备

基于多域名的虚拟主机实现,其实就是读个server标签   

环境准备,
1个linux服务器, ip地址:10.0.0.129

安装好nginx软件

在windows中写入2个hosts假的域名
找到如下文件,编辑写入域名对应关系(C:\windows\System32\drivers\etc\hosts)

10.0.0.129 www.dbjwb.com
10.0.0.129 www.dbjapi.com

2.2 修给nginx.conf的配置,

  • 实现多虚拟主机,多个server{}标签是同级的关系

2.2.1 server

# 第一个主机,域名部分替换为你自己的域名,此处是随意写的
server {
        # 监听的端口号 
        listen       80;
        server_name  www.yourdomain1.com;
        location / {
            # root参数定义网页的根目录,
            root   /opt/api/;
            # 指定首页文件的名字,两个都是,可以删掉一个
            index  index.html;
        }
} 
# 第二个主机
server {
        listen  80;
        server_name  www.yourdomain2.com;
        location / {
            root   /opt/wb/;
            index  index.html;
        }
}   

2.2.2 完整配置

# 进程数
worker_processes  1;
events {
    worker_connections  1024;
}
# 核心代码
http {
    include       mime.types;
    default_type  application/octet-stream;
    # 定义nginx访问日志的格式 
    log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';
    # 访问日志的功能
    access_log  logs/access.log  main;
    # 推图片等静态文件压缩,提升传输效率
    gizp  on;
    #server被称为虚拟主机,可以有多个
    # 第一个主机
    server {
        # 监听的端口号 
        listen       80;
        server_name  www.yourdomain1.com;
        location / {
            # root参数定义网页的根目录,
            root   /opt/api/;
            # 指定首页文件的名字,两个都是,可以删掉一个
            index  index.html;
        }
} 
# 第二个主机
server {
        listen  80;
        server_name  www.yourdomain2.com;
        location / {
            root   /opt/wb/;
            index  index.html;
        }
}   
}

2.2.3 创建文件夹/index.html

新建文件夹  
mkdir -p /opt/{api,wb}

各自新建一个index.html,写入内容,随便找一个html
vim index.html

2.3 重启nginx

nginx -s reload

2.4 访问对应的域名,即可看见内容

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/5124

赞 (4)
安屠生的头像安屠生
上一篇 2022年6月22日 下午3:12
下一篇 2022年6月24日 下午3:42

相关推荐

  • 部署 OVA 时出现“OVF 软件包无效且无法部署”错误

    通过 vSphere Client 部署 OVA 失败。 您会看到以下错误 Cause 出现此问题的原因是,vSphere Client 不支持最新 VIC OVA(从 1.1.1 开始)包含的 SHA256 哈希算法。 在使用 Get-Ovf Configuration cmdlet 时,还会影响通过 PowerCLI 进行的任何 OVA 部署。 Reso…

    2023年8月11日
    2.5K00
  • 又见问题之-Windows Server 2012 R2 安装.net 4.6.1

    服务器是新版的Windows Server 2012 R2 ,今天安装一个软件,软件需要(.net v4.6.1)环境,发现报错,缺少.Netframework, Version=v4.6.1,直接下载对应版本的.Netframework 连续点击是,会跳转到 .net 的下载页面,选中所需的 .net 版本 下载安装之后报错,你需要先安装 对应于 KB29…

    2023年10月25日
    2.4K00
  • 爽了!免费的SSL,还能自动续期!

    兄弟👬🏻,当你手里有不少域名,每个域名又配置子域名,那么ssl将是一笔不小的费用。当然各个云厂商,也都有提供免费的ssl证书,但这里有一个问题,就是基本都不提供免费的泛域名证书(免费20个单域名证书),比如 x.gaga.plus、b.gaga.plus 这就要申请2个域名证书了!并且3个月就过期,一年就折腾这,都能折腾哭😭!那咋办? 像我这样做技术分享的,…

    2024年6月4日
    1.6K00
  • VMware vSphere中三种磁盘规格(厚置备延迟置零\厚置备置零\Thin Provision)

    在VMware vSphere中,不管是以前的5.1版本,或者是现在的6.5版本,创建虚拟机时,在创建磁盘时,都会让选择磁盘的置备类型,如下图所示,分为: (1)厚置备延迟置零; (2)厚置备置零; (3)Thin Provision(精简置备)。 在创建虚拟机时,可以选择这三种类型的其中一种,如下图所示 这三种类型的磁盘,每一种类型的磁…

    2023年8月11日
    1.4K00
  • LAMP环境下部署DiscuzQ

    一、安装Apachae yum安装Apache,并设置开机自启动 在网页浏览器输入ip地址,查看Apache是否正常 二、安装配置 MariaDB 执行以下命令,查看系统中是否已安装 MariaDB。 rpm -qa | grep -i mariadb       返回结果类似如下内容,则表示已存在 MariaDB。 &nbsp…

    2022年12月6日
    2.0K00

发表回复

您的邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信