pve集群的部署

一、部署前准备

需准备一台物理机,安装hyper-v(需开启虚拟化)或者vmware

proxmox镜像下载地址:https://www.proxmox.com/en/downloads

二、安装系统

确认物理机是否开启虚拟化

  1. 打开系统信息
    • 在 Windows 中,按下 Win + R 打开运行对话框,输入 msinfo32,然后按回车。
  2. 查看虚拟化信息
    • 在系统信息中,找到左侧导航栏中的 “系统摘要”。
    • 在右侧窗格中,查找 “虚拟化” 或类似的部分。
    • 在这里,你应该能够找到有关虚拟化技术的信息,如 “虚拟化启用中” 或类似的字段。

新建三台虚拟机

pve集群的部署
pve集群的部署
pve集群的部署
pve集群的部署
pve集群的部署

之后就自动安装。

装完后新建一个内部虚拟交换机,使物理机与虚拟机能够内网相通。

https:// 192.168.1.11:8006进入web页面

pve1节点弄完后,pve2,pve3节点也这样弄

三.proxmox集群搭建

pve集群的部署
pve集群的部署

四、配置外网

新建外部虚拟交换机,并给三个虚拟机都加上外部交换机。

pve集群的部署

编辑网卡配置文件,添加公网IP

nano /etc/network/interfaces
pve集群的部署

重启网络服务

service networking restart

测试是否连通外网

ping baidu.com
pve集群的部署

五、安装ceph

pve集群的部署

点击安装会出现弹窗,根据自己的pve是否有凭证选择安装的ceph版本。

六、ceph集群设置

pve集群的部署

清除磁盘数据

pve集群的部署

选择未使用的数据盘,创建osd

pve集群的部署

创建ceph pool,名称自定义

pve集群的部署

ceph监视器将所有pve节点都配置监视

pve集群的部署

配置CephFS

pve集群的部署

”数据中心“ — ”存储“ — ”添加“ — ”RBD“ 添加存储池RBD至PVE

七、虚拟机创建

pve集群的部署

上传所需镜像

pve集群的部署

点击创建虚拟机,选择自己所需系统配置及磁盘存放节点

文章来源:https://www.cnaaa.net,转载请注明出处:https://www.cnaaa.net/archives/10182

(0)
杰斯的头像杰斯
上一篇 2023年12月5日 下午2:36
下一篇 2023年12月6日 下午3:46

相关推荐

  • 限制登录Linux服务器的几种方式

    在日常运维中,我们通常使用防火墙iptables跟firewalld的方式来实现访问控制,但在实际环境中,开启防火墙可能会对业务造成影响,所以以下整理了三种限制登录Linux服务器的几种方式。分别是修改TCP Wrappers服务访问控制、修改sshd_config配置文件、防火墙策略iptables跟firewalld。以上三种方式可以针对安全厂商做的漏洞…

    2023年2月28日
    37700
  • NetSet – 自动化网络流量安全增强工具

    NetSet旨在自动执行多个操作,以帮助用户保护网络流量。它还提供了一种通过Tor收集代理和运行实用程序的简便方法。NetSet安装和使用的也是自动配置,该工具主要用于辅助性网络安全任务。 实现了一种按需使用的终端多路复用器,它的会话通过Tor路由网关。通过自动安装和配置DNSCrypt-proxy来保护DNS流量。Tor Wall功能强制所有流量通过Tor…

    2023年10月8日
    31000
  • 查看调整cpu频率及模式

    使用cpufrequtils查看调整cpu频率及模式 cpufrequtils是一个查看和修改CPU频率GHz的工具有些物理服务器使用默认频率进行运行,这时可以使用该工具进行就该CPU的核心频率 安装: 使用: cpufreq-info 查看当前cpu状态 参数: 参数 值 说明 -c CPU序号 查看所指定cpu状态 -f 查看cpu当前频率 -l 查看c…

    2023年11月3日
    27600
  • 解决Composer Installing dependencies from lock file

    1、问题描述 2、原因 这是因为不匹配composer.json要求的版本。提示我的PHP 7版本太高,不符合composer.json需要的版本,但是在PHP 7下应该也是可以运行的,composer可以设置忽略版本匹配。 3、解决方案 composer install –ignore-platform-reqs 或者 composer update -…

    2023年2月14日
    49800
  • 此站点的连接不安全,使用不受支持的协议。ERR_SSL_VERSION_OR_CIPHER_MISMATCH(不支持的协议 客户端和服务器不支持常用的 SSL 协议版本或密码套件。)

    此站点的连接不安全,使用不受支持的协议。ERR_SSL_VERSION_OR_CIPHER_MISMATCH(不支持的协议 客户端和服务器不支持常用的 SSL 协议版本或密码套件。) 前言 之前自己的电脑未更新系统或者浏览器的时候使用的是IE浏览器,更新后变成了Microsoft Edge浏览器。导致之前很多访问的地址无法法访问了 如图所…

    2024年3月27日
    37300

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注

在线咨询: QQ交谈

邮件:712342017@qq.com

工作时间:周一至周五,8:30-17:30,节假日休息

关注微信